CVE-2019-14751 NLTK Vulnerable To Path Traversal

High 7.5 Published Updated

Attackers can write arbitrary files via directory traversal in NLTK Downloader when extracting malicious ZIP archives.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-14751?

CVE-2019-14751 is a high-severity path traversal vulnerability in n/a, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

NLTK Downloader before 3.4.5 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in an NLTK package (ZIP archive) that is mishandled during extraction.

Weakness: CWE-22

Which versions are affected by CVE-2019-14751?

3 open source packages ship an affected version, including nltk. It affects 1 product.

PackageAffectedFixed in
nltk PyPIAll versions3.4.5
nltk PyPIAll versions3.4.5
nltk PyPIAll versions3.4.5
Linux distribution packages (3)
python-nltk SUSE:Package Hub 15 SP1All versions3.4.5-bp151.4.3.1
python-nltk openSUSE:Leap 15.1All versions3.4.5-lp151.4.3.1
python-nltk openSUSE:TumbleweedAll versions3.5-1.10

Products include Nltk Nltk.

How do I fix CVE-2019-14751?

Upgrade nltk to 3.4.5 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2019-14751 being exploited?

There is no known exploitation of CVE-2019-14751 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as DEBIAN-CVE-2019-14751, GHSA-mr7p-25v2-35wr, MGASA-2020-0160, PYSEC-2019-106, UBUNTU-CVE-2019-14751, USN-4106-1 and 3 more.

Is CVE-2019-14751 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free