# CVE-2019-14751: NLTK Vulnerable To Path Traversal

> Attackers can write arbitrary files via directory traversal in NLTK Downloader when extracting malicious ZIP archives.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-14751, GHSA-mr7p-25v2-35wr, MGASA-2020-0160, PYSEC-2019-106, UBUNTU-CVE-2019-14751, USN-4106-1, openSUSE-SU-2020:0436-1, openSUSE-SU-2020:0440-1, openSUSE-SU-2024:11241-1

## What is CVE-2019-14751?

CVE-2019-14751 is a high-severity path traversal vulnerability in n/a, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLTK Downloader before 3.4.5 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in an NLTK package (ZIP archive) that is mishandled during extraction.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-14751?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.4.5 |
| `nltk` | PyPI | All versions | 3.4.5 |
| `nltk` | PyPI | All versions | 3.4.5 |
| `python-nltk` | SUSE:Package Hub 15 SP1 | All versions | 3.4.5-bp151.4.3.1 |
| `python-nltk` | openSUSE:Leap 15.1 | All versions | 3.4.5-lp151.4.3.1 |
| `python-nltk` | openSUSE:Tumbleweed | All versions | 3.5-1.10 |

Products: Nltk Nltk.

## How do I fix CVE-2019-14751?

Upgrade nltk to 3.4.5 or later.

## Is CVE-2019-14751 being exploited?

There is no known exploitation of CVE-2019-14751 in the wild and no public exploit code.

Public exploit code:

- A Proof of Concept for CVE-2019-14751 (github_poc): https://github.com/mssalvatore/CVE-2019-14751_PoC

## Other vulnerabilities in n/a

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14751 and fix it if it is affected.

What it is: CVE-2019-14751 is a high-severity path traversal vulnerability in n/a, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14751 in the wild and no public exploit code.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.4.5
- nltk (PyPI): affected all versions; fixed in 3.4.5
- nltk (PyPI): affected all versions; fixed in 3.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14751/ (Markdown: https://insights.sbomify.com/CVE-2019-14751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14751
- OSV: https://osv.dev/vulnerability/CVE-2019-14751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14751/
Summaries are generated and may contain mistakes; the official description above is the record.
