# CVE-2019-14802: Hashicorp Nomad Information Exposure Through Environmental Variables

> HashiCorp Nomad leaks unintended environment variables to rendering tasks, allowing attackers to read sensitive configuration data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2022
- **Updated:** 14 Apr 2025
- **Also known as:** GHSA-6hv3-7c34-4hx8, GO-2022-0634, UBUNTU-CVE-2019-14802

## What is CVE-2019-14802?

CVE-2019-14802 is a medium-severity vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Nomad 0.5.0 through 0.9.4 (fixed in 0.9.5) reveals unintended environment variables to the rendering task during template rendering, aka GHSA-6hv3-7c34-4hx8. This applies to nomad/client/allocrunner/taskrunner/template.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2019-14802?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | All versions | 0.9.5 |
| `github.com/hashicorp/nomad` | Go | All versions | 0.9.5 |
| `github.com/hashicorp/nomad` | Go | All versions | 0.9.5 |

Products: Hashicorp Nomad.

## How do I fix CVE-2019-14802?

Upgrade github.com/hashicorp/nomad to 0.9.5 or later.

## Is CVE-2019-14802 being exploited?

There is no known exploitation of CVE-2019-14802 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14802 and fix it if it is affected.

What it is: CVE-2019-14802 is a medium-severity vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14802 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 0.9.5
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 0.9.5
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 0.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14802/ (Markdown: https://insights.sbomify.com/CVE-2019-14802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14802
- OSV: https://osv.dev/vulnerability/CVE-2019-14802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14802/
Summaries are generated and may contain mistakes; the official description above is the record.
