# CVE-2019-14806: Pallets Werkzeug Insufficient Entropy

> Insufficient debugger PIN randomness in Werkzeug when used with Docker allows attackers to bypass debugger authentication.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-14806, GHSA-gq9m-qvpx-68hc, MGASA-2020-0004, PYSEC-2019-140, SUSE-SU-2019:2308-1, SUSE-SU-2019:2358-1, SUSE-SU-2019:2365-1, SUSE-SU-2019:2365-2, SUSE-SU-2019:2400-1, SUSE-SU-2022:3977-1, UBUNTU-CVE-2019-14806, openSUSE-SU-2019:2118-1, openSUSE-SU-2019:2145-1, openSUSE-SU-2024:11213-1

## What is CVE-2019-14806?

CVE-2019-14806 is a high-severity vulnerability in Opensuse Leap, published on 9 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pallets Werkzeug before 0.15.3, when used with Docker, has insufficient debugger PIN randomness because Docker containers share the same machine id.

Weakness: CWE-331 (Insufficient Entropy)

## Which versions are affected by CVE-2019-14806?

3 open source packages ship an affected version, including werkzeug. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `werkzeug` | PyPI | All versions | 0.15.3 |
| `werkzeug` | PyPI | All versions | 0.15.3 |
| `werkzeug` | PyPI | All versions | 0.15.3 |
| `python-Werkzeug` | SUSE:HPE Helion OpenStack 8 | All versions | 0.12.2-3.3.1 |
| `python-Werkzeug` | SUSE:Linux Enterprise Module for Basesystem 15 | All versions | 0.12.2-3.3.1 |
| `python-Werkzeug` | SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 0.14.1-6.3.1 |
| `python-Werkzeug` | SUSE:Linux Enterprise Module for Package Hub 15 | All versions | 0.12.2-3.3.1 |
| `python-Werkzeug` | SUSE:Linux Enterprise Module for Package Hub 15 SP1 | All versions | 0.14.1-6.3.1 |
| `python-Werkzeug` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 0.12.2-10.10.1 |
| `python-Werkzeug` | SUSE:OpenStack Cloud 8 | All versions | 0.12.2-3.3.1 |
| `python-Werkzeug` | SUSE:OpenStack Cloud 9 | All versions | 0.14.1-3.3.1 |
| `python-Werkzeug` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 0.12.2-3.3.1 |
| `python-Werkzeug` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 0.14.1-3.3.1 |
| `python-Werkzeug` | openSUSE:Leap 15.0 | All versions | 0.12.2-lp150.2.3.1 |
| `python-Werkzeug-doc` | openSUSE:Leap 15.0 | All versions | 0.12.2-lp150.2.3.1 |
| `python-Werkzeug` | openSUSE:Leap 15.1 | All versions | 0.14.1-lp151.2.3.1 |
| `python-Werkzeug-doc` | openSUSE:Leap 15.1 | All versions | 0.14.1-lp151.2.3.1 |
| `python-Werkzeug` | openSUSE:Tumbleweed | All versions | 2.0.1-1.2 |

Products: Opensuse Leap, Palletsprojects Werkzeug.

## How do I fix CVE-2019-14806?

Upgrade werkzeug to 0.15.3 or later.

## Is CVE-2019-14806 being exploited?

There is no known exploitation of CVE-2019-14806 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Leap

- [CVE-2015-4902](https://insights.sbomify.com/CVE-2015-4902/): Oracle Java SE Integrity Check (medium 5.3, exploited in the wild)
- [CVE-2017-14804](https://insights.sbomify.com/CVE-2017-14804/): package builds could use directory traversal to write outside of target area (critical 9.9)
- [CVE-2019-20787](https://insights.sbomify.com/CVE-2019-20787/): Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size. (critical 9.8)
- [CVE-2019-8341](https://insights.sbomify.com/CVE-2019-8341/): Code injection in n/a (critical 9.8)
- [CVE-2019-6438](https://insights.sbomify.com/CVE-2019-6438/): Other in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14806 and fix it if it is affected.

What it is: CVE-2019-14806 is a high-severity vulnerability in Opensuse Leap, published on 9 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14806 in the wild and no public exploit code.

Affected packages and fixed versions:
- werkzeug (PyPI): affected all versions; fixed in 0.15.3
- werkzeug (PyPI): affected all versions; fixed in 0.15.3
- werkzeug (PyPI): affected all versions; fixed in 0.15.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14806/ (Markdown: https://insights.sbomify.com/CVE-2019-14806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14806
- OSV: https://osv.dev/vulnerability/CVE-2019-14806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14806/
Summaries are generated and may contain mistakes; the official description above is the record.
