# CVE-2019-14825: Katello cleartext password storage issue

> Attackers with privileged access can read unmasked registry credentials from logs in Katello, exposing sensitive authentication data.

- **Severity:** Medium 4.1 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m4wh-848j-9w2r

## What is CVE-2019-14825?

CVE-2019-14825 is a medium-severity vulnerability in Red Hat katello, published on 25 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A cleartext password storage issue was discovered in Katello, versions 3.x.x.x before katello 3.12.0.9. Registry credentials used during container image discovery were inadvertently logged without being masked. This flaw could expose the registry credentials to other privileged users.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2019-14825?

2 open source packages ship an affected version, including katello. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `katello` | RubyGems | From 3.0.0.0 | 3.12.2 |
| `katello` | RubyGems | From 3.0.0.0 | 3.12.2 |

Products: Theforeman Katello.

## How do I fix CVE-2019-14825?

Upgrade katello to 3.12.2 or later.

## Is CVE-2019-14825 being exploited?

There is no known exploitation of CVE-2019-14825 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat katello

- [CVE-2013-4120](https://insights.sbomify.com/CVE-2013-4120/): Denial of service in Katello (high 7.5)
- [CVE-2013-0283](https://insights.sbomify.com/CVE-2013-0283/): Cross-site scripting in Katello (medium 5.4)
- [CVE-2018-14623](https://insights.sbomify.com/CVE-2018-14623/): katello SQL Injection vulnerability (medium 4.3)
- [CVE-2017-2662](https://insights.sbomify.com/CVE-2017-2662/): katello Improper Privilege Management vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14825 and fix it if it is affected.

What it is: CVE-2019-14825 is a medium-severity vulnerability in Red Hat katello, published on 25 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14825 in the wild and no public exploit code.

Affected packages and fixed versions:
- katello (RubyGems): affected from 3.0.0.0; fixed in 3.12.2
- katello (RubyGems): affected from 3.0.0.0; fixed in 3.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14825/ (Markdown: https://insights.sbomify.com/CVE-2019-14825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14825
- OSV: https://osv.dev/vulnerability/CVE-2019-14825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14825/
Summaries are generated and may contain mistakes; the official description above is the record.
