# CVE-2019-14837: keycloak vulnerable to unauthorized login via mail server setup

> An attacker controlling a specific domain can reset passwords for Keycloak service accounts by exploiting hardcoded email generation logic, leading to account takeover.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-cf8f-w2c5-p5jr

## What is CVE-2019-14837?

CVE-2019-14837 is a critical vulnerability in Redhat Keycloak, published on 7 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in keycloack before version 8.0.0. The owner of 'placeholder.org' domain can setup mail server on this domain and knowing only name of a client can reset password and then log in. For example, for client name 'test' the email address will be 'service-account-test@placeholder.org'.

Weakness: CWE-798 (Use of Hard-coded Credentials), CWE-547 (Use of Hard-coded, Security-relevant Constants)

## Which versions are affected by CVE-2019-14837?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 8.0.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 8.0.0 |

Products: Redhat Keycloak, Redhat Single Sign-On.

## How do I fix CVE-2019-14837?

Upgrade org.keycloak:keycloak-core to 8.0.0 or later.

## Is CVE-2019-14837 being exploited?

There is no known exploitation of CVE-2019-14837 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14837 and fix it if it is affected.

What it is: CVE-2019-14837 is a critical vulnerability in Redhat Keycloak, published on 7 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14837 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 8.0.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 8.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14837/ (Markdown: https://insights.sbomify.com/CVE-2019-14837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14837
- OSV: https://osv.dev/vulnerability/CVE-2019-14837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14837/
Summaries are generated and may contain mistakes; the official description above is the record.
