# CVE-2019-14838: Wildfly Authorization Misconfiguration

> Monitor, Auditor, and Deployer roles can improperly modify server runtime state, allowing unauthorized privilege escalation and configuration changes.

- **Severity:** Medium 5.2 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-82v2-f875-73g9, RHSA-2019:3082

## What is CVE-2019-14838?

CVE-2019-14838 is a medium-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 14 Oct 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A flaw was found in wildfly-core before 7.2.5.GA. The Management users with Monitor, Auditor and Deployer Roles should not be allowed to modify the runtime state of the server

Weakness: CWE-269 (Improper Privilege Management), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2019-14838?

2 open source packages ship an affected version, including org.wildfly.core:wildfly-host-controller. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wildfly.core:wildfly-host-controller` | Maven | All versions | 7.2.5.GA |
| `org.wildfly.core:wildfly-host-controller` | Maven | All versions | 7.2.5.GA |
| `eap7-wildfly` | Red Hat:jboss_enterprise_application_platform:7.2::el6 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el6eap |
| `eap7-wildfly-javadocs` | Red Hat:jboss_enterprise_application_platform:7.2::el6 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el6eap |
| `eap7-wildfly-modules` | Red Hat:jboss_enterprise_application_platform:7.2::el6 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el6eap |
| `eap7-wildfly` | Red Hat:jboss_enterprise_application_platform:7.2::el7 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el7eap |
| `eap7-wildfly-java-jdk11` | Red Hat:jboss_enterprise_application_platform:7.2::el7 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el7eap |
| `eap7-wildfly-java-jdk8` | Red Hat:jboss_enterprise_application_platform:7.2::el7 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el7eap |
| `eap7-wildfly-javadocs` | Red Hat:jboss_enterprise_application_platform:7.2::el7 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el7eap |
| `eap7-wildfly-modules` | Red Hat:jboss_enterprise_application_platform:7.2::el7 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el7eap |
| `eap7-wildfly` | Red Hat:jboss_enterprise_application_platform:7.2::el8 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el8eap |
| `eap7-wildfly-javadocs` | Red Hat:jboss_enterprise_application_platform:7.2::el8 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el8eap |
| `eap7-wildfly-modules` | Red Hat:jboss_enterprise_application_platform:7.2::el8 | All versions | 0:7.2.4-2.SP1_redhat_00001.1.el8eap |

Products: Redhat Data Grid, Redhat Jboss Enterprise Application Platform, Redhat Single Sign-On, Redhat Wildfly Core.

## How do I fix CVE-2019-14838?

Upgrade org.wildfly.core:wildfly-host-controller to 7.2.5.GA or later.

## Is CVE-2019-14838 being exploited?

There is no known exploitation of CVE-2019-14838 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2015-7501](https://insights.sbomify.com/CVE-2015-7501/): Deserialization of Untrusted Data in Apache commons collections (critical 9.8)
- [CVE-2025-23368](https://insights.sbomify.com/CVE-2025-23368/): Org.wildfly.core:wildfly-elytron-integration: wildfly elytron brute force attack via cli (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14838 and fix it if it is affected.

What it is: CVE-2019-14838 is a medium-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 14 Oct 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-14838 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wildfly.core:wildfly-host-controller (Maven): affected all versions; fixed in 7.2.5.GA
- org.wildfly.core:wildfly-host-controller (Maven): affected all versions; fixed in 7.2.5.GA

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14838/ (Markdown: https://insights.sbomify.com/CVE-2019-14838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14838
- OSV: https://osv.dev/vulnerability/CVE-2019-14838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14838/
Summaries are generated and may contain mistakes; the official description above is the record.
