{"answers":{"affected":"7 open source packages ship an affected version, including ansible. It affects 5 products.","exploited":"There is no known exploitation of CVE-2019-14846 in the wild and no public exploit code.","fix":"Upgrade ansible to a fixed version for your release line: 2.6.20, 2.7.14 or 2.8.6.","what":"CVE-2019-14846 is a high-severity vulnerability in Debian Debian Linux, published on 8 Oct 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-14846 and fix it if it is affected.\n\nWhat it is: CVE-2019-14846 is a high-severity vulnerability in Debian Debian Linux, published on 8 Oct 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-14846 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 2.6.20, 2.7.14, 2.8.6\n- ansible (PyPI): affected all versions; fixed in 2.6.20\n- ansible (PyPI): affected all versions; fixed in 2.6.20\n- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.14\n- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.14\n- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.6\n- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-14846/ (Markdown: https://insights.sbomify.com/CVE-2019-14846/index.md)","id":"CVE-2019-14846","markdown":"https://insights.sbomify.com/CVE-2019-14846/index.md","name":"CVE-2019-14846","record":{"aliases":["ALPINE-CVE-2019-14846","CLSA-2025-1744628190","DEBIAN-CVE-2019-14846","GHSA-pm48-cvv2-29q5","PYSEC-2019-4","UBUNTU-CVE-2019-14846"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Ansible automation tool","requires_auth":"low_privilege","summary":"Ansible logs credentials at DEBUG level if plugins use libraries that do so, exposing sensitive data to anyone with log access.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"},{"product":"ansible_engine","vendor":"redhat"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"},{"id":"CWE-117","name":"Improper Output Neutralization for Logs"}],"description":"In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible Uses Plugins That Disclose Credentials","id":"CVE-2019-14846","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux","opensuse:backports_sle","opensuse:leap","redhat:openstack"],"type":"information_disclosure","year":"2019"},"n_packages":7,"n_references":12,"next":{"headline":"Null dereference in samba","id":"CVE-2019-14847"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.20","2.7.14","2.8.6"],"introduced":["0","2.7.0","2.8.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2019-4"},{"ecosystem":"PyPI","fixed":["2.6.20"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-pm48-cvv2-29q5"},{"ecosystem":"PyPI","fixed":["2.6.20"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-pm48-cvv2-29q5"},{"ecosystem":"PyPI","fixed":["2.7.14"],"introduced":["2.7.0a1"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-pm48-cvv2-29q5"},{"ecosystem":"PyPI","fixed":["2.7.14"],"introduced":["2.7.0a1"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-pm48-cvv2-29q5"},{"ecosystem":"PyPI","fixed":["2.8.6"],"introduced":["2.8.0a1"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-pm48-cvv2-29q5"},{"ecosystem":"PyPI","fixed":["2.8.6"],"introduced":["2.8.0a1"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-pm48-cvv2-29q5"}],"prev":{"headline":"Security feature bypass in openshift","id":"CVE-2019-14845"},"products":["Ansible"],"published":"2019-10-08","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat"]},"summary":"Ansible logs credentials at DEBUG level if plugins use libraries that do so, exposing sensitive data to anyone with log access.","url":"https://insights.sbomify.com/CVE-2019-14846/"}