# CVE-2019-14846: Ansible Uses Plugins That Disclose Credentials

> Ansible logs credentials at DEBUG level if plugins use libraries that do so, exposing sensitive data to anyone with log access.

- **Severity:** High 7.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2019-14846, CLSA-2025-1744628190, DEBIAN-CVE-2019-14846, GHSA-pm48-cvv2-29q5, PYSEC-2019-4, UBUNTU-CVE-2019-14846

## What is CVE-2019-14846?

CVE-2019-14846 is a high-severity vulnerability in Debian Debian Linux, published on 8 Oct 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2019-14846?

7 open source packages ship an affected version, including ansible. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.6.20, 2.7.14, 2.8.6 |
| `ansible` | PyPI | All versions | 2.6.20 |
| `ansible` | PyPI | All versions | 2.6.20 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.14 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.14 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.6 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.6 |

Products: Debian Debian Linux, Opensuse Backports Sle, Opensuse Leap, Redhat Ansible Engine, Redhat Openstack.

## How do I fix CVE-2019-14846?

Upgrade ansible to a fixed version for your release line: 2.6.20, 2.7.14 or 2.8.6.

## Is CVE-2019-14846 being exploited?

There is no known exploitation of CVE-2019-14846 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14846 and fix it if it is affected.

What it is: CVE-2019-14846 is a high-severity vulnerability in Debian Debian Linux, published on 8 Oct 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-14846 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.6.20, 2.7.14, 2.8.6
- ansible (PyPI): affected all versions; fixed in 2.6.20
- ansible (PyPI): affected all versions; fixed in 2.6.20
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.14
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.14
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.6
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14846/ (Markdown: https://insights.sbomify.com/CVE-2019-14846/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14846
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14846
- OSV: https://osv.dev/vulnerability/CVE-2019-14846

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14846/
Summaries are generated and may contain mistakes; the official description above is the record.
