{"answers":{"affected":"5 open source packages ship an affected version, including ecdsa. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-14853 in the wild and no public exploit code.","fix":"Upgrade ecdsa to 0.13.3 or later.","what":"CVE-2019-14853 is a low-severity denial of service vulnerability in [UNKNOWN] python-ecdsa, published on 26 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-14853 and fix it if it is affected.\n\nWhat it is: CVE-2019-14853 is a low-severity denial of service vulnerability in [UNKNOWN] python-ecdsa, published on 26 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-14853 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ecdsa (PyPI): affected all versions; fixed in 0.13.3\n- ecdsa (PyPI): affected all versions; fixed in 0.13.3\n- ecdsa (PyPI): affected all versions; fixed in 0.13.3\n- ecdsa (PyPI): affected all versions; fixed in 0.13.3\n- ecdsa (PyPI): affected all versions; fixed in 0.13.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-14853/ (Markdown: https://insights.sbomify.com/CVE-2019-14853/index.md)","id":"CVE-2019-14853","markdown":"https://insights.sbomify.com/CVE-2019-14853/index.md","name":"CVE-2019-14853","record":{"aliases":["DEBIAN-CVE-2019-14853","GHSA-2mrj-435v-c2cr","GHSA-pwfw-mgfj-7g3g","PYSEC-2019-177","UBUNTU-CVE-2019-14853"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python ECDSA library","requires_auth":"none","summary":"Attackers can cause a denial of service in applications using the python-ecdsa library by submitting malformed DER signatures that trigger unexpected exceptions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"python-ecdsa","vendor":"python-ecdsa_project"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.0"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"},{"id":"CWE-391","name":"DEPRECATED: Unchecked Error Condition"}],"description":"An error-handling flaw was found in python-ecdsa before version 0.13.3. During signature decoding, malformed DER signatures could raise unexpected exceptions (or no exceptions at all), which could lead to a denial of service.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Duplicate Advisory: possible DoS caused by malformed signature decoding in Pure-Python ECDSA","id":"CVE-2019-14853","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":5,"n_references":4,"next":{"headline":"Information disclosure in library-go","id":"CVE-2019-14854"},"packages":[{"ecosystem":"PyPI","fixed":["0.13.3"],"introduced":["0"],"last_affected":[],"package":"ecdsa","purl":null,"source":"GHSA-2mrj-435v-c2cr"},{"ecosystem":"PyPI","fixed":["0.13.3"],"introduced":["0"],"last_affected":[],"package":"ecdsa","purl":"pkg:pypi/ecdsa","source":"GHSA-2mrj-435v-c2cr"},{"ecosystem":"PyPI","fixed":["0.13.3"],"introduced":["0"],"last_affected":[],"package":"ecdsa","purl":null,"source":"GHSA-pwfw-mgfj-7g3g"},{"ecosystem":"PyPI","fixed":["0.13.3"],"introduced":["0"],"last_affected":[],"package":"ecdsa","purl":"pkg:pypi/ecdsa","source":"GHSA-pwfw-mgfj-7g3g"},{"ecosystem":"PyPI","fixed":["0.13.3"],"introduced":["0"],"last_affected":[],"package":"ecdsa","purl":"pkg:pypi/ecdsa","source":"PYSEC-2019-177"}],"prev":{"headline":"A flaw was found in 3scale’s APIcast gateway that enabled the TLS 1.0 protocol.","id":"CVE-2019-14852"},"products":["python-ecdsa"],"published":"2019-11-26","related":[{"cvss_score":7.4,"headline":"Improper Verification of Cryptographic Signature in Pure-Python ECDSA","id":"CVE-2019-14859","kev_date_added":null,"published":"2020-01-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["[UNKNOWN]"]},"summary":"Attackers can cause a denial of service in applications using the python-ecdsa library by submitting malformed DER signatures that trigger unexpected exceptions.","url":"https://insights.sbomify.com/CVE-2019-14853/"}