{"answers":{"affected":"7 open source packages ship an affected version, including ansible. It affects 4 products.","exploited":"There is no known exploitation of CVE-2019-14856 in the wild and no public exploit code.","fix":"Upgrade ansible to a fixed version for your release line: 2.6.20, 2.7.14 or 2.8.6.","what":"CVE-2019-14856 is a medium-severity authentication bypass vulnerability in Opensuse Backports Sle, published on 26 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-14856 and fix it if it is affected.\n\nWhat it is: CVE-2019-14856 is a medium-severity authentication bypass vulnerability in Opensuse Backports Sle, published on 26 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-14856 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected from 2.6.0; fixed in 2.6.20, 2.7.14, 2.8.6\n- ansible (PyPI): affected from 2.6.0; fixed in 2.6.20\n- ansible (PyPI): affected from 2.6.0; fixed in 2.6.20\n- ansible (PyPI): affected from 2.7.0; fixed in 2.7.14\n- ansible (PyPI): affected from 2.7.0; fixed in 2.7.14\n- ansible (PyPI): affected from 2.8.0; fixed in 2.8.6\n- ansible (PyPI): affected from 2.8.0; fixed in 2.8.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-14856/ (Markdown: https://insights.sbomify.com/CVE-2019-14856/index.md)","id":"CVE-2019-14856","markdown":"https://insights.sbomify.com/CVE-2019-14856/index.md","name":"CVE-2019-14856","record":{"aliases":["ALPINE-CVE-2019-14856","GHSA-6fq2-x65v-v9h7","PYSEC-2019-146"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"low_privilege","summary":"Ansible contains an authentication bypass vulnerability allowing attackers to circumvent security controls.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"},{"product":"ansible","vendor":"redhat"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible password prompts could expose passwords","id":"CVE-2019-14856","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"opensuse:backports_sle","products":["opensuse:backports_sle","opensuse:leap","redhat:openstack"],"type":"auth_bypass","year":"2019"},"n_packages":7,"n_references":4,"next":{"headline":"Open redirect in mod auth openidc","id":"CVE-2019-14857"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.20","2.7.14","2.8.6"],"introduced":["2.6.0","2.7.0","2.8.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2019-146"},{"ecosystem":"PyPI","fixed":["2.6.20"],"introduced":["2.6.0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-6fq2-x65v-v9h7"},{"ecosystem":"PyPI","fixed":["2.6.20"],"introduced":["2.6.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-6fq2-x65v-v9h7"},{"ecosystem":"PyPI","fixed":["2.7.14"],"introduced":["2.7.0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-6fq2-x65v-v9h7"},{"ecosystem":"PyPI","fixed":["2.7.14"],"introduced":["2.7.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-6fq2-x65v-v9h7"},{"ecosystem":"PyPI","fixed":["2.8.6"],"introduced":["2.8.0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-6fq2-x65v-v9h7"},{"ecosystem":"PyPI","fixed":["2.8.6"],"introduced":["2.8.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-6fq2-x65v-v9h7"}],"prev":{"headline":"Weak cryptography in gnupg2","id":"CVE-2019-14855"},"products":["ansible"],"published":"2019-11-26","related":[{"cvss_score":9.8,"headline":"Roundcube Webmail Remote Code Execution","id":"CVE-2020-12641","kev_date_added":"2023-06-22","published":"2020-05-04"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2020-12640","kev_date_added":null,"published":"2020-05-04"},{"cvss_score":8.8,"headline":"Command injection in EdgeSwitch firmware v1.9.0 and prior","id":"CVE-2020-8233","kev_date_added":null,"published":"2020-08-17"},{"cvss_score":8.4,"headline":"inn: non-root owned files","id":"CVE-2020-8026","kev_date_added":null,"published":"2020-08-07"},{"cvss_score":8.2,"headline":"Path traversal and files overwrite with unsquashfs","id":"CVE-2020-15229","kev_date_added":null,"published":"2020-10-14"},{"cvss_score":7.8,"headline":"Command injection in Shadowsocks","id":"CVE-2019-5164","kev_date_added":null,"published":"2019-12-03"},{"cvss_score":7.8,"headline":"Path traversal in n/a","id":"CVE-2019-9896","kev_date_added":null,"published":"2019-03-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["[UNKNOWN]"]},"summary":"Ansible contains an authentication bypass vulnerability allowing attackers to circumvent security controls.","url":"https://insights.sbomify.com/CVE-2019-14856/"}