# CVE-2019-14856: Ansible password prompts could expose passwords

> Ansible contains an authentication bypass vulnerability allowing attackers to circumvent security controls.

- **Severity:** Medium 6.4 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2019-14856, GHSA-6fq2-x65v-v9h7, PYSEC-2019-146

## What is CVE-2019-14856?

CVE-2019-14856 is a medium-severity authentication bypass vulnerability in Opensuse Backports Sle, published on 26 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2019-14856?

7 open source packages ship an affected version, including ansible. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.6.0 | 2.6.20, 2.7.14, 2.8.6 |
| `ansible` | PyPI | From 2.6.0 | 2.6.20 |
| `ansible` | PyPI | From 2.6.0 | 2.6.20 |
| `ansible` | PyPI | From 2.7.0 | 2.7.14 |
| `ansible` | PyPI | From 2.7.0 | 2.7.14 |
| `ansible` | PyPI | From 2.8.0 | 2.8.6 |
| `ansible` | PyPI | From 2.8.0 | 2.8.6 |

Products: Opensuse Backports Sle, Opensuse Leap, Redhat Ansible, Redhat Openstack.

## How do I fix CVE-2019-14856?

Upgrade ansible to a fixed version for your release line: 2.6.20, 2.7.14 or 2.8.6.

## Is CVE-2019-14856 being exploited?

There is no known exploitation of CVE-2019-14856 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Backports Sle

- [CVE-2020-12641](https://insights.sbomify.com/CVE-2020-12641/): Roundcube Webmail Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2020-12640](https://insights.sbomify.com/CVE-2020-12640/): Path traversal in n/a (critical 9.8)
- [CVE-2020-8233](https://insights.sbomify.com/CVE-2020-8233/): Command injection in EdgeSwitch firmware v1.9.0 and prior (high 8.8)
- [CVE-2020-8026](https://insights.sbomify.com/CVE-2020-8026/): inn: non-root owned files (high 8.4)
- [CVE-2020-15229](https://insights.sbomify.com/CVE-2020-15229/): Path traversal and files overwrite with unsquashfs (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14856 and fix it if it is affected.

What it is: CVE-2019-14856 is a medium-severity authentication bypass vulnerability in Opensuse Backports Sle, published on 26 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-14856 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.6.0; fixed in 2.6.20, 2.7.14, 2.8.6
- ansible (PyPI): affected from 2.6.0; fixed in 2.6.20
- ansible (PyPI): affected from 2.6.0; fixed in 2.6.20
- ansible (PyPI): affected from 2.7.0; fixed in 2.7.14
- ansible (PyPI): affected from 2.7.0; fixed in 2.7.14
- ansible (PyPI): affected from 2.8.0; fixed in 2.8.6
- ansible (PyPI): affected from 2.8.0; fixed in 2.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14856/ (Markdown: https://insights.sbomify.com/CVE-2019-14856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14856
- OSV: https://osv.dev/vulnerability/CVE-2019-14856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14856/
Summaries are generated and may contain mistakes; the official description above is the record.
