CVE-2019-14858 Ansible leaks sensitive information to logs when told not to
Attackers can view sensitive no_log data in Ansible task output if invalid parameters are passed and verbosity is increased.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-14858?
CVE-2019-14858 is a high-severity vulnerability in Redhat Ansible Tower, published on 14 Oct 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to the module will cause the task to fail before the no_log options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.
Which versions are affected by CVE-2019-14858?
9 open source packages ship an affected version, including ansible. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | From 2.0 | 2.6.20 |
ansible PyPI | From 2.0 | 2.6.20 |
ansible PyPI | From 2.0 | 2.8.1 |
ansible PyPI | From 2.7.0a1 | 2.7.14 |
ansible PyPI | From 2.7.0a1 | 2.7.14 |
ansible PyPI | From 2.8.0a1 | 2.8.6 |
3 more packages
ansible PyPI | From 2.8.0a1 | 2.8.6 |
ansible PyPI | From 2.9.0a1 | 2.9.0rc4 |
ansible PyPI | From 2.9.0a1 | 2.9.0rc4 |
Products include Redhat Ansible Engine, Redhat Ansible Tower.
How do I fix CVE-2019-14858?
Upgrade ansible to a fixed version for your release line: 2.6.20, 2.8.1, 2.7.14 or 2.8.6.
Is CVE-2019-14858 being exploited?
There is no known exploitation of CVE-2019-14858 in the wild and no public exploit code.
Other vulnerabilities in Redhat Ansible Tower
Sources
Also known as ALPINE-CVE-2019-14858, DEBIAN-CVE-2019-14858, GHSA-h653-95qw-h2mp, PYSEC-2019-171, UBUNTU-CVE-2019-14858.