{"answers":{"affected":"9 open source packages ship an affected version, including ansible. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-14858 in the wild and no public exploit code.","fix":"Upgrade ansible to a fixed version for your release line: 2.6.20, 2.8.1, 2.7.14 or 2.8.6.","what":"CVE-2019-14858 is a high-severity vulnerability in Redhat Ansible Tower, published on 14 Oct 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-14858 and fix it if it is affected.\n\nWhat it is: CVE-2019-14858 is a high-severity vulnerability in Redhat Ansible Tower, published on 14 Oct 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-14858 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected from 2.0; fixed in 2.6.20\n- ansible (PyPI): affected from 2.0; fixed in 2.6.20\n- ansible (PyPI): affected from 2.0; fixed in 2.8.1\n- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.14\n- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.14\n- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.6\n- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.6\n- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.0rc4\n- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.0rc4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-14858/ (Markdown: https://insights.sbomify.com/CVE-2019-14858/index.md)","id":"CVE-2019-14858","markdown":"https://insights.sbomify.com/CVE-2019-14858/index.md","name":"CVE-2019-14858","record":{"aliases":["ALPINE-CVE-2019-14858","DEBIAN-CVE-2019-14858","GHSA-h653-95qw-h2mp","PYSEC-2019-171","UBUNTU-CVE-2019-14858"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Ansible automation engine","requires_auth":"low_privilege","summary":"Attackers can view sensitive no_log data in Ansible task output if invalid parameters are passed and verbosity is increased.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible_engine","vendor":"redhat"},{"product":"ansible_tower","vendor":"redhat"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"},{"id":"CWE-117","name":"Improper Output Neutralization for Logs"}],"description":"A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to the module will cause the task to fail before the no_log options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible leaks sensitive information to logs when told not to","id":"CVE-2019-14858","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:ansible_tower","products":["redhat:ansible_tower"],"type":"information_disclosure","year":"2019"},"n_packages":9,"n_references":8,"next":{"headline":"Improper Verification of Cryptographic Signature in Pure-Python ECDSA","id":"CVE-2019-14859"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.20"],"introduced":["2.0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-h653-95qw-h2mp"},{"ecosystem":"PyPI","fixed":["2.6.20"],"introduced":["2.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-h653-95qw-h2mp"},{"ecosystem":"PyPI","fixed":["2.8.1"],"introduced":["2.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2019-171"},{"ecosystem":"PyPI","fixed":["2.7.14"],"introduced":["2.7.0a1"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-h653-95qw-h2mp"},{"ecosystem":"PyPI","fixed":["2.7.14"],"introduced":["2.7.0a1"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-h653-95qw-h2mp"},{"ecosystem":"PyPI","fixed":["2.8.6"],"introduced":["2.8.0a1"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-h653-95qw-h2mp"},{"ecosystem":"PyPI","fixed":["2.8.6"],"introduced":["2.8.0a1"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-h653-95qw-h2mp"},{"ecosystem":"PyPI","fixed":["2.9.0rc4"],"introduced":["2.9.0a1"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-h653-95qw-h2mp"},{"ecosystem":"PyPI","fixed":["2.9.0rc4"],"introduced":["2.9.0a1"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-h653-95qw-h2mp"}],"prev":{"headline":"Open redirect in mod auth openidc","id":"CVE-2019-14857"},"products":["Ansible"],"published":"2019-10-14","related":[{"cvss_score":7.8,"headline":"Ansible Improper Input Validation vulnerability","id":"CVE-2018-10874","kev_date_added":null,"published":"2018-07-02"},{"cvss_score":7.5,"headline":"Path Traversal in Ansible","id":"CVE-2020-1737","kev_date_added":null,"published":"2020-03-09"},{"cvss_score":7.4,"headline":"OS Command Injection in ansible","id":"CVE-2020-1734","kev_date_added":null,"published":"2020-03-03"},{"cvss_score":5.2,"headline":"Path Traversal in Ansible","id":"CVE-2020-10691","kev_date_added":null,"published":"2020-04-30"},{"cvss_score":4.2,"headline":"Ansible Logs Passwords If PowerShell ScriptBlock is Enabled","id":"CVE-2018-16859","kev_date_added":null,"published":"2018-11-29"},{"cvss_score":2.2,"headline":"Improper Input Validation in ansible","id":"CVE-2016-8647","kev_date_added":null,"published":"2018-07-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat"]},"summary":"Attackers can view sensitive no_log data in Ansible task output if invalid parameters are passed and verbosity is increased.","url":"https://insights.sbomify.com/CVE-2019-14858/"}