{"answers":{"affected":"3 open source packages ship an affected version, including ecdsa. It affects 4 products.","exploited":"There is no known exploitation of CVE-2019-14859 in the wild and no public exploit code.","fix":"Upgrade ecdsa to 0.13.3 or later.","what":"CVE-2019-14859 is a high-severity vulnerability in Redhat Openstack, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-14859 and fix it if it is affected.\n\nWhat it is: CVE-2019-14859 is a high-severity vulnerability in Redhat Openstack, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-14859 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ecdsa (PyPI): affected all versions; fixed in 0.13.3\n- ecdsa (PyPI): affected all versions; fixed in 0.13.3\n- ecdsa (PyPI): affected all versions; fixed in 0.13.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-14859/ (Markdown: https://insights.sbomify.com/CVE-2019-14859/index.md)","id":"CVE-2019-14859","markdown":"https://insights.sbomify.com/CVE-2019-14859/index.md","name":"CVE-2019-14859","record":{"aliases":["DEBIAN-CVE-2019-14859","GHSA-8qxj-f9rh-9fg2","PYSEC-2020-163","UBUNTU-CVE-2019-14859"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python ECDSA library","requires_auth":"none","summary":"Attackers can exploit signature malleability in the python-ecdsa library to create false transactions by bypassing DER encoding verification.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"python-ecdsa","vendor":"python-ecdsa_project"},{"product":"ceph_storage","vendor":"redhat"},{"product":"openstack","vendor":"redhat"},{"product":"virtualization","vendor":"redhat"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted, making the signature malleable. Without proper verification, an attacker could use a malleable signature to create false transactions.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Verification of Cryptographic Signature in Pure-Python ECDSA","id":"CVE-2019-14859","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:openstack","products":["redhat:openstack","redhat:virtualization"],"type":"other","year":"2019"},"n_packages":3,"n_references":4,"next":{"headline":"Misconfiguration in syndesis","id":"CVE-2019-14860"},"packages":[{"ecosystem":"PyPI","fixed":["0.13.3"],"introduced":["0"],"last_affected":[],"package":"ecdsa","purl":null,"source":"GHSA-8qxj-f9rh-9fg2"},{"ecosystem":"PyPI","fixed":["0.13.3"],"introduced":["0"],"last_affected":[],"package":"ecdsa","purl":"pkg:pypi/ecdsa","source":"GHSA-8qxj-f9rh-9fg2"},{"ecosystem":"PyPI","fixed":["0.13.3"],"introduced":["0"],"last_affected":[],"package":"ecdsa","purl":"pkg:pypi/ecdsa","source":"PYSEC-2020-163"}],"prev":{"headline":"Ansible leaks sensitive information to logs when told not to","id":"CVE-2019-14858"},"products":["python-ecdsa"],"published":"2020-01-02","related":[{"cvss_score":3.7,"headline":"Duplicate Advisory: possible DoS caused by malformed signature decoding in Pure-Python ECDSA","id":"CVE-2019-14853","kev_date_added":null,"published":"2019-11-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat"]},"summary":"Attackers can exploit signature malleability in the python-ecdsa library to create false transactions by bypassing DER encoding verification.","url":"https://insights.sbomify.com/CVE-2019-14859/"}