# CVE-2019-14859: Improper Verification of Cryptographic Signature in Pure-Python ECDSA

> Attackers can exploit signature malleability in the python-ecdsa library to create false transactions by bypassing DER encoding verification.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2020
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-14859, GHSA-8qxj-f9rh-9fg2, PYSEC-2020-163, UBUNTU-CVE-2019-14859

## What is CVE-2019-14859?

CVE-2019-14859 is a high-severity vulnerability in Redhat Openstack, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted, making the signature malleable. Without proper verification, an attacker could use a malleable signature to create false transactions.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2019-14859?

3 open source packages ship an affected version, including ecdsa. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ecdsa` | PyPI | All versions | 0.13.3 |
| `ecdsa` | PyPI | All versions | 0.13.3 |
| `ecdsa` | PyPI | All versions | 0.13.3 |

Products: Python-Ecdsa Project Python-Ecdsa, Redhat Ceph Storage, Redhat Openstack, Redhat Virtualization.

## How do I fix CVE-2019-14859?

Upgrade ecdsa to 0.13.3 or later.

## Is CVE-2019-14859 being exploited?

There is no known exploitation of CVE-2019-14859 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openstack

- [CVE-2019-14853](https://insights.sbomify.com/CVE-2019-14853/): Duplicate Advisory: possible DoS caused by malformed signature decoding in Pure-Python ECDSA (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14859 and fix it if it is affected.

What it is: CVE-2019-14859 is a high-severity vulnerability in Redhat Openstack, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14859 in the wild and no public exploit code.

Affected packages and fixed versions:
- ecdsa (PyPI): affected all versions; fixed in 0.13.3
- ecdsa (PyPI): affected all versions; fixed in 0.13.3
- ecdsa (PyPI): affected all versions; fixed in 0.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14859/ (Markdown: https://insights.sbomify.com/CVE-2019-14859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14859
- OSV: https://osv.dev/vulnerability/CVE-2019-14859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14859/
Summaries are generated and may contain mistakes; the official description above is the record.
