{"answers":{"affected":"2 open source packages ship an affected version, including angular. It affects 3 products.","exploited":"There is no known exploitation of CVE-2019-14863 in the wild and no public exploit code.","fix":"Upgrade angular to 1.5.0-beta.1 or later.","what":"CVE-2019-14863 is a high-severity cross-site scripting vulnerability in Red Hat angular:, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-14863 and fix it if it is affected.\n\nWhat it is: CVE-2019-14863 is a high-severity cross-site scripting vulnerability in Red Hat angular:, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-14863 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- angular (npm): affected all versions; fixed in 1.5.0-beta.1\n- angular (npm): affected all versions; fixed in 1.5.0-beta.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-14863/ (Markdown: https://insights.sbomify.com/CVE-2019-14863/index.md)","id":"CVE-2019-14863","markdown":"https://insights.sbomify.com/CVE-2019-14863/index.md","name":"CVE-2019-14863","record":{"aliases":["DEBIAN-CVE-2019-14863","DLA-1995-1","GHSA-r5fx-8r73-v86c","ROOT-APP-NPM-CVE-2019-14863","UBUNTU-CVE-2019-14863"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Angular JavaScript library","requires_auth":"none","summary":"An attacker can inject malicious scripts into web applications using vulnerable Angular versions, leading to potential code execution in the user's browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"angularjs","vendor":"angularjs"},{"product":"decision_manager","vendor":"redhat"},{"product":"process_automation","vendor":"redhat"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"There is a vulnerability in all angular versions before 1.5.0-beta.0, where after escaping the context of the web application, the web application delivers data to its users along with other trusted dynamic content, without validating it.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AngularJS Cross-site Scripting due to failure to sanitize `xlink.href` attributes","id":"CVE-2019-14863","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Inclusion of Sensitive Information in Log Files and Improper Output Neutralization for Logs in Ansible","id":"CVE-2019-14864"},"packages":[{"ecosystem":"npm","fixed":["1.5.0-beta.1"],"introduced":["0"],"last_affected":[],"package":"angular","purl":null,"source":"GHSA-r5fx-8r73-v86c"},{"ecosystem":"npm","fixed":["1.5.0-beta.1"],"introduced":["0"],"last_affected":[],"package":"angular","purl":"pkg:npm/angular","source":"GHSA-r5fx-8r73-v86c"}],"prev":{"headline":"XSS in knockout","id":"CVE-2019-14862"},"products":["angular:"],"published":"2020-01-02","related":[{"cvss_score":7.5,"headline":"angular Prototype Pollution vulnerability","id":"CVE-2019-10768","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":5.4,"headline":"Angular vulnerable to Cross-site Scripting","id":"CVE-2020-7676","kev_date_added":null,"published":"2020-06-08"},{"cvss_score":5.3,"headline":"angular vulnerable to regular expression denial of service via the angular.copy() utility","id":"CVE-2023-26116","kev_date_added":null,"published":"2023-03-30"},{"cvss_score":5.3,"headline":"angular vulnerable to regular expression denial of service via the $resource service","id":"CVE-2023-26117","kev_date_added":null,"published":"2023-03-30"},{"cvss_score":5.3,"headline":"angular vulnerable to regular expression denial of service via the \u003cinput type=\"url\"\u003e element","id":"CVE-2023-26118","kev_date_added":null,"published":"2023-03-30"},{"cvss_score":5.3,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2022-25844","kev_date_added":null,"published":"2022-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat"]},"summary":"An attacker can inject malicious scripts into web applications using vulnerable Angular versions, leading to potential code execution in the user's browser.","url":"https://insights.sbomify.com/CVE-2019-14863/"}