CVE-2019-14864 Inclusion of Sensitive Information in Log Files and Improper Output Neutralization for Logs in Ansible
Ansible fails to respect no_log flags in Sumologic and Splunk callbacks, exposing sensitive task data to collectors.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-14864?
CVE-2019-14864 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no_log set it to True when Sumologic and Splunk callback plugins are used send tasks results events to collectors. This would discloses and collects any sensitive data.
Which versions are affected by CVE-2019-14864?
7 open source packages ship an affected version, including ansible. It affects 8 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | From 2.7.0 | 2.7.15, 2.8.7, 2.9.1 |
ansible PyPI | From 2.7.0a1 | 2.7.15 |
ansible PyPI | From 2.7.0a1 | 2.7.15 |
ansible PyPI | From 2.8.0a1 | 2.8.7 |
ansible PyPI | From 2.8.0a1 | 2.8.7 |
ansible PyPI | From 2.9.0a1 | 2.9.1 |
1 more packages
ansible PyPI | From 2.9.0a1 | 2.9.1 |
Linux distribution packages (11)
ansible Red Hat:ansible_engine:2.7::el7 | All versions | 0:2.7.15-1.el7ae |
ansible Red Hat:ansible_engine:2.8::el7 | All versions | 0:2.8.7-1.el7ae |
ansible Red Hat:ansible_engine:2.8::el8 | All versions | 0:2.8.7-1.el8ae |
ansible Red Hat:ansible_engine:2.9::el7 | All versions | 0:2.9.1-1.el7 |
ansible-test Red Hat:ansible_engine:2.9::el7 | All versions | 0:2.9.1-1.el7 |
ansible Red Hat:ansible_engine:2.9::el8 | All versions | 0:2.9.1-1.el8 |
ansible-test Red Hat:ansible_engine:2.9::el8 | All versions | 0:2.9.1-1.el8 |
ansible Red Hat:ansible_engine:2::el7 | All versions | 0:2.9.1-1.el7 |
ansible-test Red Hat:ansible_engine:2::el7 | All versions | 0:2.9.1-1.el7 |
ansible Red Hat:ansible_engine:2::el8 | All versions | 0:2.9.1-1.el8 |
ansible-test Red Hat:ansible_engine:2::el8 | All versions | 0:2.9.1-1.el8 |
Products include Debian Debian Linux, Opensuse Backports Sle, Opensuse Leap, Redhat Ansible, Redhat Ansible Tower, Redhat Ceph Storage and 2 more.
How do I fix CVE-2019-14864?
Upgrade ansible to a fixed version for your release line: 2.7.15, 2.8.7 or 2.9.1.
Is CVE-2019-14864 being exploited?
There is no known exploitation of CVE-2019-14864 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2019-14864, DEBIAN-CVE-2019-14864, GHSA-3m93-m4q6-mc6v, MGASA-2019-0358, PYSEC-2020-160, RHSA-2019:3925 and 3 more.