# CVE-2019-14864: Inclusion of Sensitive Information in Log Files and Improper Output Neutralization for Logs in Ansible

> Ansible fails to respect no_log flags in Sumologic and Splunk callbacks, exposing sensitive task data to collectors.

- **Severity:** Medium 5.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jan 2020
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2019-14864, DEBIAN-CVE-2019-14864, GHSA-3m93-m4q6-mc6v, MGASA-2019-0358, PYSEC-2020-160, RHSA-2019:3925, RHSA-2019:3926, RHSA-2019:3927, RHSA-2019:3928

## What is CVE-2019-14864?

CVE-2019-14864 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no_log set it to True when Sumologic and Splunk callback plugins are used send tasks results events to collectors. This would discloses and collects any sensitive data.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2019-14864?

7 open source packages ship an affected version, including ansible. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.7.0 | 2.7.15, 2.8.7, 2.9.1 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.15 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.15 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.7 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.7 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.1 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.1 |
| `ansible` | Red Hat:ansible_engine:2.7::el7 | All versions | 0:2.7.15-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.8::el7 | All versions | 0:2.8.7-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.8::el8 | All versions | 0:2.8.7-1.el8ae |
| `ansible` | Red Hat:ansible_engine:2.9::el7 | All versions | 0:2.9.1-1.el7 |
| `ansible-test` | Red Hat:ansible_engine:2.9::el7 | All versions | 0:2.9.1-1.el7 |
| `ansible` | Red Hat:ansible_engine:2.9::el8 | All versions | 0:2.9.1-1.el8 |
| `ansible-test` | Red Hat:ansible_engine:2.9::el8 | All versions | 0:2.9.1-1.el8 |
| `ansible` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.9.1-1.el7 |
| `ansible-test` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.9.1-1.el7 |
| `ansible` | Red Hat:ansible_engine:2::el8 | All versions | 0:2.9.1-1.el8 |
| `ansible-test` | Red Hat:ansible_engine:2::el8 | All versions | 0:2.9.1-1.el8 |

Products: Debian Debian Linux, Opensuse Backports Sle, Opensuse Leap, Redhat Ansible, Redhat Ansible Tower, Redhat Ceph Storage, Redhat Cloudforms Management Engine, Redhat Enterprise Linux.

## How do I fix CVE-2019-14864?

Upgrade ansible to a fixed version for your release line: 2.7.15, 2.8.7 or 2.9.1.

## Is CVE-2019-14864 being exploited?

There is no known exploitation of CVE-2019-14864 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14864 and fix it if it is affected.

What it is: CVE-2019-14864 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-14864 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.7.0; fixed in 2.7.15, 2.8.7, 2.9.1
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.15
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.15
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.7
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.7
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.1
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14864/ (Markdown: https://insights.sbomify.com/CVE-2019-14864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14864
- OSV: https://osv.dev/vulnerability/CVE-2019-14864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14864/
Summaries are generated and may contain mistakes; the official description above is the record.
