# CVE-2019-14867: Code injection in FreeIPA

> An unauthenticated attacker can trigger arbitrary code execution or crash the IPA server by exploiting a flaw in Kerberos key data parsing.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-14867, GHSA-7hpj-hfcr-5qwm, PYSEC-2019-28, PYSEC-2026-636, UBUNTU-CVE-2019-14867

## What is CVE-2019-14867?

CVE-2019-14867 is a high-severity code injection vulnerability in Fedoraproject Fedora, published on 27 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way the internal function ber_scanf() was used in some components of the IPA server, which parsed kerberos key data. An unauthenticated attacker who could trigger parsing of the krb principal key could cause the IPA server to crash or in some conditions, cause arbitrary code to be executed on the server hosting the IPA server.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-14867?

14 open source packages ship an affected version, including freeipa and ipa. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `freeipa` | PyPI | From 4.6.2 | 4.6.7, 4.7.4, 4.8.3 |
| `freeipa` | PyPI | From 4.6.2 | 4.6.7 |
| `freeipa` | PyPI | From 4.6.2 | 4.6.7 |
| `freeipa` | PyPI | From 4.7.0 | 4.7.4 |
| `freeipa` | PyPI | From 4.7.0 | 4.7.4 |
| `freeipa` | PyPI | From 4.8.0 | 4.8.3 |
| `freeipa` | PyPI | From 4.8.0 | 4.8.3 |
| `ipa` | PyPI | From 4.6.2 | 4.6.7, 4.7.4, 4.8.3 |
| `ipa` | PyPI | From 4.6.2 | 4.6.7 |
| `ipa` | PyPI | From 4.6.2 | 4.6.7 |
| `ipa` | PyPI | From 4.7.0 | 4.7.4 |
| `ipa` | PyPI | From 4.7.0 | 4.7.4 |
| `ipa` | PyPI | From 4.8.0 | 4.8.3 |
| `ipa` | PyPI | From 4.8.0 | 4.8.3 |

Products: Fedoraproject Fedora, Freeipa Freeipa.

## How do I fix CVE-2019-14867?

Upgrade freeipa to a fixed version for your release line: 4.6.7, 4.7.4 or 4.8.3.

## Is CVE-2019-14867 being exploited?

There is no known exploitation of CVE-2019-14867 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14867 and fix it if it is affected.

What it is: CVE-2019-14867 is a high-severity code injection vulnerability in Fedoraproject Fedora, published on 27 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-14867 in the wild and no public exploit code.

Affected packages and fixed versions:
- freeipa (PyPI): affected from 4.6.2; fixed in 4.6.7, 4.7.4, 4.8.3
- freeipa (PyPI): affected from 4.6.2; fixed in 4.6.7
- freeipa (PyPI): affected from 4.6.2; fixed in 4.6.7
- freeipa (PyPI): affected from 4.7.0; fixed in 4.7.4
- freeipa (PyPI): affected from 4.7.0; fixed in 4.7.4
- freeipa (PyPI): affected from 4.8.0; fixed in 4.8.3
- freeipa (PyPI): affected from 4.8.0; fixed in 4.8.3
- ipa (PyPI): affected from 4.6.2; fixed in 4.6.7, 4.7.4, 4.8.3
- ipa (PyPI): affected from 4.6.2; fixed in 4.6.7
- ipa (PyPI): affected from 4.6.2; fixed in 4.6.7
- ipa (PyPI): affected from 4.7.0; fixed in 4.7.4
- ipa (PyPI): affected from 4.7.0; fixed in 4.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14867/ (Markdown: https://insights.sbomify.com/CVE-2019-14867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14867
- OSV: https://osv.dev/vulnerability/CVE-2019-14867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14867/
Summaries are generated and may contain mistakes; the official description above is the record.
