CVE-2019-14879 Moodle does not revoke role capabilities correctly
Attackers retain unauthorized capabilities after cohort role removal, allowing privilege escalation in Moodle installations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-14879?
CVE-2019-14879 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 7 Jan 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).
Which versions are affected by CVE-2019-14879?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.5.0 | 3.5.9 |
moodle/moodle Packagist | From 3.5.0 | 3.5.9 |
moodle/moodle Packagist | From 3.6.0 | 3.6.7 |
moodle/moodle Packagist | From 3.6.0 | 3.6.7 |
moodle/moodle Packagist | From 3.7.0 | 3.7.3 |
moodle/moodle Packagist | From 3.7.0 | 3.7.3 |
Products include Moodle Moodle.
How do I fix CVE-2019-14879?
Upgrade moodle/moodle to a fixed version for your release line: 3.5.9, 3.6.7 or 3.7.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2019-14879 being exploited?
There is no known exploitation of CVE-2019-14879 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-g9m2-c2x5-fr2v, UBUNTU-CVE-2019-14879.