CVE-2019-14880 Moodle Oauth 2 Insufficiently Protects Against Compromise

Medium 4.8 Published Updated

Attackers can compromise accounts if OAuth 2 providers do not verify email changes, requiring additional verification during sign-up.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-14880?

CVE-2019-14880 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 31 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was found in Moodle versions 3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9 and earlier. OAuth 2 providers who do not verify users' email address changes require additional verification during sign-up to reduce the risk of account compromise.

Weakness: CWE-287

Which versions are affected by CVE-2019-14880?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 3.5.03.5.9
moodle/moodle PackagistFrom 3.5.03.5.9
moodle/moodle PackagistFrom 3.6.03.6.7
moodle/moodle PackagistFrom 3.6.03.6.7
moodle/moodle PackagistFrom 3.7.03.7.3
moodle/moodle PackagistFrom 3.7.03.7.3

Products include Moodle Moodle.

How do I fix CVE-2019-14880?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.9, 3.6.7 or 3.7.3.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2019-14880 being exploited?

There is no known exploitation of CVE-2019-14880 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-rv62-6f56-j83w, UBUNTU-CVE-2019-14880.

Is CVE-2019-14880 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free