CVE-2019-14881 Moodle XSS Vulnerability
Attackers can inject malicious scripts via user email fields in Moodle, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-14881?
CVE-2019-14881 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 18 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A vulnerability was found in moodle 3.7 before 3.7.3, where there is blind XSS reflected in some locations where user email is displayed.
Weakness: CWE-79
Which versions are affected by CVE-2019-14881?
2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.7.0 | 3.7.3 |
moodle/moodle Packagist | From 3.7.0 | 3.7.3 |
Products include Moodle Moodle.
How do I fix CVE-2019-14881?
Upgrade moodle/moodle to 3.7.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-14881 being exploited?
There is no known exploitation of CVE-2019-14881 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-9jf6-wq34-fg9w, UBUNTU-CVE-2019-14881.