CVE-2019-14882 Moodle open redirect vulnerability
An open redirect in the Lesson edit page allows attackers to redirect users to malicious sites, potentially facilitating phishing attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-14882?
CVE-2019-14882 is a low-severity vulnerability in Moodle Moodle, published on 18 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A vulnerability was found in Moodle 3.7 to 3.7.3, 3.6 to 3.6.7, 3.5 to 3.5.9 and earlier where an open redirect existed in the Lesson edit page.
Weakness: CWE-601
Which versions are affected by CVE-2019-14882?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.5 | 3.5.9 |
moodle/moodle Packagist | From 3.5 | 3.5.9 |
moodle/moodle Packagist | From 3.6 | 3.6.7 |
moodle/moodle Packagist | From 3.6 | 3.6.7 |
moodle/moodle Packagist | From 3.7 | 3.7.3 |
moodle/moodle Packagist | From 3.7 | 3.7.3 |
Products include Moodle Moodle.
How do I fix CVE-2019-14882?
Upgrade moodle/moodle to a fixed version for your release line: 3.5.9, 3.6.7 or 3.7.3.
Is CVE-2019-14882 being exploited?
There is no known exploitation of CVE-2019-14882 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-m98q-q59p-r9fv.