CVE-2019-14884 Moodle reflected Cross-site Scripting (XSS)

Medium 6.1 Published Updated

Attackers can execute arbitrary scripts in victim browsers via reflected XSS in Moodle fatal error messages, potentially leading to session hijacking.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-14884?

CVE-2019-14884 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 18 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in Moodle 3.7 before 3.73, 3.6 before 3.6.7 and 3.5 before 3.5.9, where a reflected XSS possible from some fatal error messages.

Weakness: CWE-79

Which versions are affected by CVE-2019-14884?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 3.5.03.5.9
moodle/moodle PackagistFrom 3.5.03.5.9
moodle/moodle PackagistFrom 3.6.03.6.7
moodle/moodle PackagistFrom 3.6.03.6.7
moodle/moodle PackagistFrom 3.7.03.7.3
moodle/moodle PackagistFrom 3.7.03.7.3

Products include Moodle Moodle.

How do I fix CVE-2019-14884?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.9, 3.6.7 or 3.7.3.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-14884 being exploited?

There is no known exploitation of CVE-2019-14884 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-3xh5-5v5v-mfgm, UBUNTU-CVE-2019-14884.

Is CVE-2019-14884 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free