{"answers":{"affected":"6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-14884 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.5.9, 3.6.7 or 3.7.3.","what":"CVE-2019-14884 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 18 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-14884 and fix it if it is affected.\n\nWhat it is: CVE-2019-14884 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 18 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-14884 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.9\n- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.9\n- moodle/moodle (Packagist): affected from 3.6.0; fixed in 3.6.7\n- moodle/moodle (Packagist): affected from 3.6.0; fixed in 3.6.7\n- moodle/moodle (Packagist): affected from 3.7.0; fixed in 3.7.3\n- moodle/moodle (Packagist): affected from 3.7.0; fixed in 3.7.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-14884/ (Markdown: https://insights.sbomify.com/CVE-2019-14884/index.md)","id":"CVE-2019-14884","markdown":"https://insights.sbomify.com/CVE-2019-14884/index.md","name":"CVE-2019-14884","record":{"aliases":["GHSA-3xh5-5v5v-mfgm","UBUNTU-CVE-2019-14884"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victim browsers via reflected XSS in Moodle fatal error messages, potentially leading to session hijacking.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Moodle 3.7 before 3.73, 3.6 before 3.6.7 and 3.5 before 3.5.9, where a reflected XSS possible from some fatal error messages.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle reflected Cross-site Scripting (XSS)","id":"CVE-2019-14884","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2019"},"n_packages":6,"n_references":2,"next":{"headline":"Information disclosure in JBoss EAP","id":"CVE-2019-14885"},"packages":[{"ecosystem":"Packagist","fixed":["3.5.9"],"introduced":["3.5.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-3xh5-5v5v-mfgm"},{"ecosystem":"Packagist","fixed":["3.5.9"],"introduced":["3.5.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-3xh5-5v5v-mfgm"},{"ecosystem":"Packagist","fixed":["3.6.7"],"introduced":["3.6.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-3xh5-5v5v-mfgm"},{"ecosystem":"Packagist","fixed":["3.6.7"],"introduced":["3.6.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-3xh5-5v5v-mfgm"},{"ecosystem":"Packagist","fixed":["3.7.3"],"introduced":["3.7.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-3xh5-5v5v-mfgm"},{"ecosystem":"Packagist","fixed":["3.7.3"],"introduced":["3.7.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-3xh5-5v5v-mfgm"}],"prev":{"headline":"Moodle Email media URL tokens were not checking for user status","id":"CVE-2019-14883"},"products":["moodle"],"published":"2020-03-18","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["[UNKNOWN]"]},"summary":"Attackers can execute arbitrary scripts in victim browsers via reflected XSS in Moodle fatal error messages, potentially leading to session hijacking.","url":"https://insights.sbomify.com/CVE-2019-14884/"}