# CVE-2019-14893: Polymorphic deserialization of malicious object in jackson-databind

> Attackers can execute arbitrary code via unsafe polymorphic deserialization in jackson-databind when default typing or specific type info annotations are enabled.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2020
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-JS33298, DEBIAN-CVE-2019-14893, GHSA-qmqc-x3r4-6v39, ROOT-APP-MAVEN-CVE-2019-14893, UBUNTU-CVE-2019-14893

## What is CVE-2019-14893?

CVE-2019-14893 is a high-severity unsafe deserialization vulnerability in Fasterxml Jackson-Databind, published on 2 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was discovered in FasterXML jackson-databind in all versions before 2.9.10 and 2.10.0, where it would permit polymorphic deserialization of malicious objects using the xalan JNDI gadget when used in conjunction with polymorphic type handling methods such as `enableDefaultTyping()` or when @JsonTypeInfo is using `Id.CLASS` or `Id.MINIMAL_CLASS` or in any other way which ObjectMapper.readValue might instantiate objects from unsafe sources. An attacker could use this flaw to execute arbitrary code.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2019-14893?

2 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.10 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.10 |

Products: Fasterxml Jackson-Databind, Netapp Oncommand Api Services, Netapp Steelstore Cloud Integrated Storage, Oracle Goldengate Stream Analytics.

## How do I fix CVE-2019-14893?

Upgrade com.fasterxml.jackson.core:jackson-databind to 2.9.10 or later.

## Is CVE-2019-14893 being exploited?

There is no known exploitation of CVE-2019-14893 in the wild and no public exploit code.

## Other vulnerabilities in Fasterxml Jackson-Databind

- [CVE-2018-11307](https://insights.sbomify.com/CVE-2018-11307/): Deserialization of Untrusted Data in jackson-databind (critical 9.8)
- [CVE-2026-54512](https://insights.sbomify.com/CVE-2026-54512/): jackson-databind: PolymorphicTypeValidator bypass via generic type parameters allows arbitrary class instantiation (high 8.1)
- [CVE-2026-54513](https://insights.sbomify.com/CVE-2026-54513/): jackson-databind: Array subtype allowlist bypass in BasicPolymorphicTypeValidator (allowIfSubTypeIsArray) (high 8.1)
- [CVE-2020-14060](https://insights.sbomify.com/CVE-2020-14060/): Deserialization of untrusted data in Jackson Databind (high 8.1)
- [CVE-2021-46877](https://insights.sbomify.com/CVE-2021-46877/): jackson-databind possible Denial of Service if using JDK serialization to serialize JsonNode (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-14893 and fix it if it is affected.

What it is: CVE-2019-14893 is a high-severity unsafe deserialization vulnerability in Fasterxml Jackson-Databind, published on 2 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-14893 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.10
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-14893/ (Markdown: https://insights.sbomify.com/CVE-2019-14893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-14893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-14893
- OSV: https://osv.dev/vulnerability/CVE-2019-14893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-14893/
Summaries are generated and may contain mistakes; the official description above is the record.
