CVE-2019-14905 Externally Controlled Reference to a Resource in Another Sphere, Improper Input Validation, and External Control of File Name or Path in Ansible
Attackers can inject OS commands via the filename parameter in Ansible's nxos_file_copy module, leading to code execution and data exposure on NXOS devices.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-14905?
CVE-2019-14905 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 31 Mar 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.
Which versions are affected by CVE-2019-14905?
7 open source packages ship an affected version, including ansible. It affects 8 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | From 2.7.0 | 2.7.16, 2.8.8, 2.9.3 |
ansible PyPI | From 2.7.0a1 | 2.7.16 |
ansible PyPI | From 2.7.0a1 | 2.7.16 |
ansible PyPI | From 2.8.0a1 | 2.8.8 |
ansible PyPI | From 2.8.0a1 | 2.8.8 |
ansible PyPI | From 2.9.0a1 | 2.9.3 |
1 more packages
ansible PyPI | From 2.9.0a1 | 2.9.3 |
Products include Fedoraproject Fedora, Opensuse Backports Sle, Opensuse Leap, Redhat Ansible Engine, Redhat Ansible Tower, Redhat Ceph Storage and 2 more.
How do I fix CVE-2019-14905?
Upgrade ansible to a fixed version for your release line: 2.7.16, 2.8.8 or 2.9.3.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2019-14905 being exploited?
There is no known exploitation of CVE-2019-14905 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2019-14905, DEBIAN-CVE-2019-14905, GHSA-frxj-5j27-f8rf, PYSEC-2020-206, UBUNTU-CVE-2019-14905.