# CVE-2019-15062: Dolibarr Cross-Site Request Forgery (CSRF)

> An attacker can hijack an admin account by storing a malicious IFRAME in settings, bypassing Referer-based CSRF protections.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4qq9-qg7j-fcm9, UBUNTU-CVE-2019-15062

## What is CVE-2019-15062?

CVE-2019-15062 is a high-severity vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 14 Aug 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Dolibarr 11.0.0-alpha. A user can store an IFRAME element (containing a user/card.php CSRF request) in his Linked Files settings page. When visited by the admin, this could completely take over the admin account. (The protection mechanism for CSRF is to check the Referer header; however, because the attack is from one of the application's own settings pages, this mechanism is bypassed.)

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-15062?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | From 10.0 | 10.0.2 |
| `dolibarr/dolibarr` | Packagist | From 10.0 | 10.0.2 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2019-15062?

Upgrade dolibarr/dolibarr to 10.0.2 or later.

## Is CVE-2019-15062 being exploited?

There is no known exploitation of CVE-2019-15062 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15062 and fix it if it is affected.

What it is: CVE-2019-15062 is a high-severity vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 14 Aug 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-15062 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected from 10.0; fixed in 10.0.2
- dolibarr/dolibarr (Packagist): affected from 10.0; fixed in 10.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15062/ (Markdown: https://insights.sbomify.com/CVE-2019-15062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15062
- OSV: https://osv.dev/vulnerability/CVE-2019-15062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15062/
Summaries are generated and may contain mistakes; the official description above is the record.
