# CVE-2019-15138: Arbitrary File Read in html-pdf

> An attacker can read arbitrary local files by crafting an HTML file that uses XMLHttpRequest to access file:/// URLs in the html-pdf library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-x4w5-r546-x9qh

## What is CVE-2019-15138?

CVE-2019-15138 is a high-severity path traversal vulnerability in n/a, published on 20 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The html-pdf package 2.2.0 for Node.js has an arbitrary file read vulnerability via an HTML file that uses XMLHttpRequest to access a file:/// URL.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2019-15138?

2 open source packages ship an affected version, including html-pdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `html-pdf` | npm | All versions | 3.0.1 |
| `html-pdf` | npm | All versions | 3.0.1 |

Products: Html-Pdf Project Html-Pdf.

## How do I fix CVE-2019-15138?

Upgrade html-pdf to 3.0.1 or later.

## Is CVE-2019-15138 being exploited?

There is no known exploitation of CVE-2019-15138 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15138 and fix it if it is affected.

What it is: CVE-2019-15138 is a high-severity path traversal vulnerability in n/a, published on 20 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15138 in the wild and no public exploit code.

Affected packages and fixed versions:
- html-pdf (npm): affected all versions; fixed in 3.0.1
- html-pdf (npm): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15138/ (Markdown: https://insights.sbomify.com/CVE-2019-15138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15138
- OSV: https://osv.dev/vulnerability/CVE-2019-15138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15138/
Summaries are generated and may contain mistakes; the official description above is the record.
