# CVE-2019-15160: Inline DTD allows XML bomb attack

> Attackers can cause denial of service via XML entity expansion in the SweetXml library for Erlang and Elixir.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-qpmc-wprv-x746

## What is CVE-2019-15160?

CVE-2019-15160 is a high-severity vulnerability in n/a, published on 19 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The SweetXml (aka sweet_xml) package through 0.6.6 for Erlang and Elixir allows attackers to cause a denial of service (resource consumption) via an XML entity expansion attack with an inline DTD.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2019-15160?

2 open source packages ship an affected version, including sweet_xml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sweet_xml` | Hex | All versions | 0.7.0 |
| `sweet_xml` | Hex | All versions | 0.7.0 |

Products: Kbrw Sweet Xml.

## How do I fix CVE-2019-15160?

Upgrade sweet_xml to 0.7.0 or later.

## Is CVE-2019-15160 being exploited?

There is no known exploitation of CVE-2019-15160 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15160 and fix it if it is affected.

What it is: CVE-2019-15160 is a high-severity vulnerability in n/a, published on 19 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15160 in the wild and no public exploit code.

Affected packages and fixed versions:
- sweet_xml (Hex): affected all versions; fixed in 0.7.0
- sweet_xml (Hex): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15160/ (Markdown: https://insights.sbomify.com/CVE-2019-15160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15160
- OSV: https://osv.dev/vulnerability/CVE-2019-15160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15160/
Summaries are generated and may contain mistakes; the official description above is the record.
