{"answers":{"affected":"2 open source packages ship an affected version, including org.jooby:jooby. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-15477 in the wild and no public exploit code.","fix":"Upgrade org.jooby:jooby to 1.6.4 or later.","what":"CVE-2019-15477 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-15477 and fix it if it is affected.\n\nWhat it is: CVE-2019-15477 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-15477 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jooby:jooby (Maven): affected all versions; fixed in 1.6.4\n- org.jooby:jooby (Maven): affected all versions; fixed in 1.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-15477/ (Markdown: https://insights.sbomify.com/CVE-2019-15477/index.md)","id":"CVE-2019-15477","markdown":"https://insights.sbomify.com/CVE-2019-15477/index.md","name":"CVE-2019-15477","record":{"aliases":["GHSA-f5f4-m7qp-w6gc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jooby web framework","requires_auth":"none","summary":"Cross-site scripting vulnerability in Jooby's default error handler allows attackers to execute arbitrary scripts in user browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jooby","vendor":"jooby"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jooby before 1.6.4 has XSS via the default error handler.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2024-05-31","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-05-31T00:09:01Z","kind":"github_poc","ref":"https://github.com/epicosy/jooby","stars":0,"title":"jooby with CVE-2019-15477"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Cross-site Scripting in Jooby","id":"CVE-2019-15477","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-Site Scripting in status-board","id":"CVE-2019-15478"},"packages":[{"ecosystem":"Maven","fixed":["1.6.4"],"introduced":["0"],"last_affected":[],"package":"org.jooby:jooby","purl":null,"source":"GHSA-f5f4-m7qp-w6gc"},{"ecosystem":"Maven","fixed":["1.6.4"],"introduced":["0"],"last_affected":[],"package":"org.jooby:jooby","purl":"pkg:maven/org.jooby/jooby","source":"GHSA-f5f4-m7qp-w6gc"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-15476"},"products":["n/a"],"published":"2019-08-23","related":[{"cvss_score":6.5,"headline":"HTTP Response Splitting","id":"CVE-2020-7622","kev_date_added":null,"published":"2020-04-06"},{"cvss_score":5.3,"headline":"path traversal in Jooby","id":"CVE-2020-7647","kev_date_added":null,"published":"2020-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in Jooby's default error handler allows attackers to execute arbitrary scripts in user browsers.","url":"https://insights.sbomify.com/CVE-2019-15477/"}