# CVE-2019-15477: Cross-site Scripting in Jooby

> Cross-site scripting vulnerability in Jooby's default error handler allows attackers to execute arbitrary scripts in user browsers.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f5f4-m7qp-w6gc

## What is CVE-2019-15477?

CVE-2019-15477 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jooby before 1.6.4 has XSS via the default error handler.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-15477?

2 open source packages ship an affected version, including org.jooby:jooby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jooby:jooby` | Maven | All versions | 1.6.4 |
| `org.jooby:jooby` | Maven | All versions | 1.6.4 |

Products: Jooby Jooby.

## How do I fix CVE-2019-15477?

Upgrade org.jooby:jooby to 1.6.4 or later.

## Is CVE-2019-15477 being exploited?

There is no known exploitation of CVE-2019-15477 in the wild and no public exploit code.

Public exploit code:

- jooby with CVE-2019-15477 (github_poc): https://github.com/epicosy/jooby

## Other vulnerabilities in n/a

- [CVE-2020-7622](https://insights.sbomify.com/CVE-2020-7622/): HTTP Response Splitting (medium 6.5)
- [CVE-2020-7647](https://insights.sbomify.com/CVE-2020-7647/): path traversal in Jooby (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15477 and fix it if it is affected.

What it is: CVE-2019-15477 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-15477 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jooby:jooby (Maven): affected all versions; fixed in 1.6.4
- org.jooby:jooby (Maven): affected all versions; fixed in 1.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15477/ (Markdown: https://insights.sbomify.com/CVE-2019-15477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15477
- OSV: https://osv.dev/vulnerability/CVE-2019-15477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15477/
Summaries are generated and may contain mistakes; the official description above is the record.
