CVE-2019-15479 Status Board vulnerable to Cross-Site Scripting before v1.1.82

Medium 6.1 Published Updated

Reflected XSS in Status Board allows attackers to execute arbitrary scripts in victim browsers, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-15479?

CVE-2019-15479 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Status Board 1.1.81 has reflected XSS via dashboard.ts.

Weakness: CWE-79

Which versions are affected by CVE-2019-15479?

2 open source packages ship an affected version, including status-board. It affects 1 product.

PackageAffectedFixed in
status-board npmAll versions1.1.82
status-board npmAll versions1.1.82

Products include Status Board Project Status Board.

How do I fix CVE-2019-15479?

Upgrade status-board to 1.1.82 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-15479 being exploited?

There is no known exploitation of CVE-2019-15479 in the wild and no public exploit code.

Sources

Also known as GHSA-8864-rhmw-5m6f.

Is CVE-2019-15479 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free