# CVE-2019-15481: Kimai v2 is vulnerable to Cross-Site Scripting (XSS)

> An attacker can inject malicious scripts into timesheet descriptions in Kimai v2, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-7v44-75jf-22gj

## What is CVE-2019-15481?

CVE-2019-15481 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Kimai v2 before 1.1 has XSS via a timesheet description.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-15481?

2 open source packages ship an affected version, including kevinpapst/kimai2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kevinpapst/kimai2` | Packagist | All versions | 1.1 |
| `kevinpapst/kimai2` | Packagist | All versions | 1.1 |

Products: Kimai Kimai 2.

## How do I fix CVE-2019-15481?

Upgrade kevinpapst/kimai2 to 1.1 or later.

## Is CVE-2019-15481 being exploited?

There is no known exploitation of CVE-2019-15481 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-4033](https://insights.sbomify.com/CVE-2021-4033/): Cross-Site Request Forgery (CSRF) in kevinpapst/kimai2 (medium 6.5)
- [CVE-2021-3957](https://insights.sbomify.com/CVE-2021-3957/): Cross-Site Request Forgery (CSRF) in kevinpapst/kimai2 (medium 4.6)
- [CVE-2021-3963](https://insights.sbomify.com/CVE-2021-3963/): Cross-Site Request Forgery (CSRF) in kevinpapst/kimai2 (medium 4.3)
- [CVE-2021-3976](https://insights.sbomify.com/CVE-2021-3976/): Cross-Site Request Forgery (CSRF) in kevinpapst/kimai2 (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15481 and fix it if it is affected.

What it is: CVE-2019-15481 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-15481 in the wild and no public exploit code.

Affected packages and fixed versions:
- kevinpapst/kimai2 (Packagist): affected all versions; fixed in 1.1
- kevinpapst/kimai2 (Packagist): affected all versions; fixed in 1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15481/ (Markdown: https://insights.sbomify.com/CVE-2019-15481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15481
- OSV: https://osv.dev/vulnerability/CVE-2019-15481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15481/
Summaries are generated and may contain mistakes; the official description above is the record.
