# CVE-2019-15482: Cross-Site Scripting in selectize-plugin-a11y

> Cross-site scripting vulnerability in selectize-plugin-a11y allows attackers to inject malicious scripts via the msg field.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8cpw-73f2-w58m

## What is CVE-2019-15482?

CVE-2019-15482 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

selectize-plugin-a11y before 1.1.0 has XSS via the msg field.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-15482?

2 open source packages ship an affected version, including selectize-plugin-a11y. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `selectize-plugin-a11y` | npm | All versions | 1.1.0 |
| `selectize-plugin-a11y` | npm | All versions | 1.1.0 |

Products: Selectize-Plugin-A11y Project Selectize-Plugin-A11y.

## How do I fix CVE-2019-15482?

Upgrade selectize-plugin-a11y to 1.1.0 or later.

## Is CVE-2019-15482 being exploited?

There is no known exploitation of CVE-2019-15482 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15482 and fix it if it is affected.

What it is: CVE-2019-15482 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-15482 in the wild and no public exploit code.

Affected packages and fixed versions:
- selectize-plugin-a11y (npm): affected all versions; fixed in 1.1.0
- selectize-plugin-a11y (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15482/ (Markdown: https://insights.sbomify.com/CVE-2019-15482/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15482
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15482
- OSV: https://osv.dev/vulnerability/CVE-2019-15482

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15482/
Summaries are generated and may contain mistakes; the official description above is the record.
