{"answers":{"affected":"2 open source packages ship an affected version, including jsdecena/laracom. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-15489 in the wild and no public exploit code.","fix":"Upgrade jsdecena/laracom to 1.5.0 or later.","what":"CVE-2019-15489 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-15489 and fix it if it is affected.\n\nWhat it is: CVE-2019-15489 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-15489 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jsdecena/laracom (Packagist): affected from 1.4.11; fixed in 1.5.0\n- jsdecena/laracom (Packagist): affected from 1.4.11; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-15489/ (Markdown: https://insights.sbomify.com/CVE-2019-15489/index.md)","id":"CVE-2019-15489","markdown":"https://insights.sbomify.com/CVE-2019-15489/index.md","name":"CVE-2019-15489","record":{"aliases":["GHSA-qc2p-6qrf-25j2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel e-commerce software","requires_auth":"none","summary":"Cross-site scripting vulnerability in Laravel FREE E-Commerce Software allows attackers to inject malicious scripts via the search parameter.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"laracom","vendor":"laracom"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"laracom (aka Laravel FREE E-Commerce Software) 1.4.11 has search?q= XSS.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"laracom Cross-site Scripting","id":"CVE-2019-15489","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Code injection in n/a","id":"CVE-2019-15490"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["1.4.11"],"last_affected":[],"package":"jsdecena/laracom","purl":null,"source":"GHSA-qc2p-6qrf-25j2"},{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["1.4.11"],"last_affected":[],"package":"jsdecena/laracom","purl":"pkg:composer/jsdecena/laracom","source":"GHSA-qc2p-6qrf-25j2"}],"prev":{"headline":"Cross-site Scripting in Ignite Realtime Openfire","id":"CVE-2019-15488"},"products":["n/a"],"published":"2019-08-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in Laravel FREE E-Commerce Software allows attackers to inject malicious scripts via the search parameter.","url":"https://insights.sbomify.com/CVE-2019-15489/"}