# CVE-2019-15489: laracom Cross-site Scripting

> Cross-site scripting vulnerability in Laravel FREE E-Commerce Software allows attackers to inject malicious scripts via the search parameter.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-qc2p-6qrf-25j2

## What is CVE-2019-15489?

CVE-2019-15489 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

laracom (aka Laravel FREE E-Commerce Software) 1.4.11 has search?q= XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-15489?

2 open source packages ship an affected version, including jsdecena/laracom. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsdecena/laracom` | Packagist | From 1.4.11 | 1.5.0 |
| `jsdecena/laracom` | Packagist | From 1.4.11 | 1.5.0 |

Products: Laracom Laracom.

## How do I fix CVE-2019-15489?

Upgrade jsdecena/laracom to 1.5.0 or later.

## Is CVE-2019-15489 being exploited?

There is no known exploitation of CVE-2019-15489 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15489 and fix it if it is affected.

What it is: CVE-2019-15489 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-15489 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsdecena/laracom (Packagist): affected from 1.4.11; fixed in 1.5.0
- jsdecena/laracom (Packagist): affected from 1.4.11; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15489/ (Markdown: https://insights.sbomify.com/CVE-2019-15489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15489
- OSV: https://osv.dev/vulnerability/CVE-2019-15489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15489/
Summaries are generated and may contain mistakes; the official description above is the record.
