# CVE-2019-15543: Out of bounds write in slice-deque

> Memory corruption in the slice-deque Rust library allows attackers to potentially execute arbitrary code or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-c3m3-c39q-pv23, RUSTSEC-2019-0002

## What is CVE-2019-15543?

CVE-2019-15543 is a critical memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the slice-deque crate before 0.2.0 for Rust. There is memory corruption in certain allocation cases.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2019-15543?

3 open source packages ship an affected version, including slice-deque. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `slice-deque` | crates.io | All versions | 0.2.0 |
| `slice-deque` | crates.io | All versions | 0.2.0 |
| `slice-deque` | crates.io | From 0.0.0-0 | 0.2.0 |

Products: Slice-Deque Project Slice-Deque.

## How do I fix CVE-2019-15543?

Upgrade slice-deque to 0.2.0 or later.

## Is CVE-2019-15543 being exploited?

There is no known exploitation of CVE-2019-15543 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-20995](https://insights.sbomify.com/CVE-2018-20995/): Memory corruption slice-deque (critical 9.8)
- [CVE-2021-29938](https://insights.sbomify.com/CVE-2021-29938/): Double free in slice-deque (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15543 and fix it if it is affected.

What it is: CVE-2019-15543 is a critical memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15543 in the wild and no public exploit code.

Affected packages and fixed versions:
- slice-deque (crates.io): affected all versions; fixed in 0.2.0
- slice-deque (crates.io): affected all versions; fixed in 0.2.0
- slice-deque (crates.io): affected from 0.0.0-0; fixed in 0.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15543/ (Markdown: https://insights.sbomify.com/CVE-2019-15543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15543
- OSV: https://osv.dev/vulnerability/CVE-2019-15543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15543/
Summaries are generated and may contain mistakes; the official description above is the record.
