CVE-2019-15544 Uncontrolled memory consumption in protobuf
High 7.5
Published
Updated
Check this codebase for CVE-2019-15544 and fix it if it is affected.
What it is: CVE-2019-15544 is a high-severity vulnerability in n/a, published on 26 Aug 2019.
Exploitation: There is no known exploitation of CVE-2019-15544 in the wild and no public exploit code.
Affected packages and fixed versions:
- protobuf (crates.io): affected all versions; fixed in 2.6.0
- protobuf (crates.io): affected all versions; fixed in 2.6.0
- protobuf (crates.io): affected from 0.0.0-0; fixed in 1.7.5, 2.6.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2019-15544/ (Markdown: https://insights.sbomify.com/CVE-2019-15544/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2019-15544?
CVE-2019-15544 is a high-severity vulnerability in n/a, published on 26 Aug 2019.
Official description
An issue was discovered in the protobuf crate before 2.6.0 for Rust. Attackers can exhaust all memory via Vec::reserve calls.
Weakness: CWE-770
Which versions are affected by CVE-2019-15544?
3 open source packages ship an affected version, including protobuf. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
protobuf crates.io | All versions | 2.6.0 |
protobuf crates.io | All versions | 2.6.0 |
protobuf crates.io | From 0.0.0-0 | 1.7.5, 2.6.0 |
Products include Apache Hbase, Rust-Protobuf Project Rust-Protobuf.
How do I fix CVE-2019-15544?
Upgrade protobuf to a fixed version for your release line: 2.6.0 or 1.7.5.
Is CVE-2019-15544 being exploited?
There is no known exploitation of CVE-2019-15544 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2018-8025 Race condition in org.apache.hbase:hbase-thrift
- CVE-2019-0212 Improper Authorization in org.apache.hbase:hbase
- CVE-2015-1836 High severity vulnerability that affects org.apache.hbase:hbase
- CVE-2026-49326 Apache HBase: Missing scanner instance owner check in thrift delegation service
- CVE-2013-2193 Security feature bypass in n/a
Sources
Also known as GHSA-mh6h-f25p-98f8, RUSTSEC-2019-0003.