# CVE-2019-15545: Failure to properly verify ed25519 signatures in libp2p-core

> Attackers can spoof ed25519 signatures in the libp2p-core Rust crate, bypassing authentication mechanisms.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4q4x-67hx-5mpg, RUSTSEC-2019-0004

## What is CVE-2019-15545?

CVE-2019-15545 is a high-severity vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the libp2p-core crate before 0.8.1 for Rust. Attackers can spoof ed25519 signatures.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2019-15545?

3 open source packages ship an affected version, including libp2p-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libp2p-core` | crates.io | All versions | 0.8.1 |
| `libp2p-core` | crates.io | All versions | 0.8.1 |
| `libp2p-core` | crates.io | From 0.3.0 | 0.7.1, 0.8.1 |

Products: Libp2p Libp2p.

## How do I fix CVE-2019-15545?

Upgrade libp2p-core to a fixed version for your release line: 0.8.1 or 0.7.1.

## Is CVE-2019-15545 being exploited?

There is no known exploitation of CVE-2019-15545 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15545 and fix it if it is affected.

What it is: CVE-2019-15545 is a high-severity vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15545 in the wild and no public exploit code.

Affected packages and fixed versions:
- libp2p-core (crates.io): affected all versions; fixed in 0.8.1
- libp2p-core (crates.io): affected all versions; fixed in 0.8.1
- libp2p-core (crates.io): affected from 0.3.0; fixed in 0.7.1, 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15545/ (Markdown: https://insights.sbomify.com/CVE-2019-15545/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15545
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15545
- OSV: https://osv.dev/vulnerability/CVE-2019-15545

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15545/
Summaries are generated and may contain mistakes; the official description above is the record.
