# CVE-2019-15549: Memory exhaustion in asn1_der

> Attackers can cause memory exhaustion and denial of service by supplying large length values to the asn1_der Rust library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-v5r6-6r3c-wqxc, RUSTSEC-2019-0007

## What is CVE-2019-15549?

CVE-2019-15549 is a high-severity denial of service vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the asn1_der crate before 0.6.2 for Rust. Attackers can trigger memory exhaustion by supplying a large value in a length field.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-15549?

3 open source packages ship an affected version, including asn1_der. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `asn1_der` | crates.io | All versions | 0.6.2 |
| `asn1_der` | crates.io | All versions | 0.6.2 |
| `asn1_der` | crates.io | From 0.0.0-0 | 0.6.2 |

Products: Asn1 Der Project Asn1 Der.

## How do I fix CVE-2019-15549?

Upgrade asn1_der to 0.6.2 or later.

## Is CVE-2019-15549 being exploited?

There is no known exploitation of CVE-2019-15549 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15549 and fix it if it is affected.

What it is: CVE-2019-15549 is a high-severity denial of service vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15549 in the wild and no public exploit code.

Affected packages and fixed versions:
- asn1_der (crates.io): affected all versions; fixed in 0.6.2
- asn1_der (crates.io): affected all versions; fixed in 0.6.2
- asn1_der (crates.io): affected from 0.0.0-0; fixed in 0.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15549/ (Markdown: https://insights.sbomify.com/CVE-2019-15549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15549
- OSV: https://osv.dev/vulnerability/CVE-2019-15549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15549/
Summaries are generated and may contain mistakes; the official description above is the record.
