# CVE-2019-15550: Out of bounds read in simd-json

> An out-of-bounds read in the simd-json Rust crate allows attackers to cause crashes or disclose memory contents.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gwfj-pw2x-h6c2, RUSTSEC-2019-0008

## What is CVE-2019-15550?

CVE-2019-15550 is a high-severity memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the simd-json crate before 0.1.15 for Rust. There is an out-of-bounds read and an incorrect crossing of a page boundary.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2019-15550?

3 open source packages ship an affected version, including simd-json. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simd-json` | crates.io | From 0.1.13 | 0.1.15 |
| `simd-json` | crates.io | From 0.1.13 | 0.1.15 |
| `simd-json` | crates.io | From 0.1.14-0 | 0.1.15 |

Products: Simdjson Project Simdjson.

## How do I fix CVE-2019-15550?

Upgrade simd-json to 0.1.15 or later.

## Is CVE-2019-15550 being exploited?

There is no known exploitation of CVE-2019-15550 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15550 and fix it if it is affected.

What it is: CVE-2019-15550 is a high-severity memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15550 in the wild and no public exploit code.

Affected packages and fixed versions:
- simd-json (crates.io): affected from 0.1.13; fixed in 0.1.15
- simd-json (crates.io): affected from 0.1.13; fixed in 0.1.15
- simd-json (crates.io): affected from 0.1.14-0; fixed in 0.1.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15550/ (Markdown: https://insights.sbomify.com/CVE-2019-15550/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15550
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15550
- OSV: https://osv.dev/vulnerability/CVE-2019-15550

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15550/
Summaries are generated and may contain mistakes; the official description above is the record.
