# CVE-2019-15554: Memory corruption in smallvec

> Memory corruption in the smallvec Rust crate allows attackers to potentially execute arbitrary code or cause denial of service via crafted grow attempts.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-15554, GHSA-69gw-hgj3-45m7, RUSTSEC-2019-0012

## What is CVE-2019-15554?

CVE-2019-15554 is a critical memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the smallvec crate before 0.6.10 for Rust. There is memory corruption for certain grow attempts with less than the current capacity.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2019-15554?

3 open source packages ship an affected version, including smallvec. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smallvec` | crates.io | From 0.6.3 | 0.6.10 |
| `smallvec` | crates.io | From 0.6.3 | 0.6.10 |
| `smallvec` | crates.io | From 0.6.3 | 0.6.10 |

Products: Servo Smallvec.

## How do I fix CVE-2019-15554?

Upgrade smallvec to 0.6.10 or later.

## Is CVE-2019-15554 being exploited?

There is no known exploitation of CVE-2019-15554 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-25900](https://insights.sbomify.com/CVE-2021-25900/): Buffer overflow in SmallVec::insert_many (critical 9.8)
- [CVE-2018-20991](https://insights.sbomify.com/CVE-2018-20991/): Double free in smallvec (critical 9.8)
- [CVE-2019-15551](https://insights.sbomify.com/CVE-2019-15551/): Double free in smallvec (critical 9.8)
- [CVE-2018-25023](https://insights.sbomify.com/CVE-2018-25023/): Use of Uninitialized Resource in smallvec (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15554 and fix it if it is affected.

What it is: CVE-2019-15554 is a critical memory corruption vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15554 in the wild and no public exploit code.

Affected packages and fixed versions:
- smallvec (crates.io): affected from 0.6.3; fixed in 0.6.10
- smallvec (crates.io): affected from 0.6.3; fixed in 0.6.10
- smallvec (crates.io): affected from 0.6.3; fixed in 0.6.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15554/ (Markdown: https://insights.sbomify.com/CVE-2019-15554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15554
- OSV: https://osv.dev/vulnerability/CVE-2019-15554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15554/
Summaries are generated and may contain mistakes; the official description above is the record.
