# CVE-2019-15563: OHDSI WebAPI vulnerable to SQL Injection

> SQL injection in OHDSI WebAPI allows attackers to read or modify database contents via the FeatureExtractionService.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2chv-87wj-pjv2

## What is CVE-2019-15563?

CVE-2019-15563 is a critical SQL injection vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Observational Health Data Sciences and Informatics (OHDSI) WebAPI before 2.7.2 allows SQL injection in FeatureExtractionService.java.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-15563?

2 open source packages ship an affected version, including org.ohdsi:WebAPI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.ohdsi:WebAPI` | Maven | All versions | 2.7.2 |
| `org.ohdsi:WebAPI` | Maven | All versions | 2.7.2 |

Products: Ohdsi Webapi.

## How do I fix CVE-2019-15563?

Upgrade org.ohdsi:WebAPI to 2.7.2 or later.

## Is CVE-2019-15563 being exploited?

There is no known exploitation of CVE-2019-15563 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15563 and fix it if it is affected.

What it is: CVE-2019-15563 is a critical SQL injection vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15563 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.ohdsi:WebAPI (Maven): affected all versions; fixed in 2.7.2
- org.ohdsi:WebAPI (Maven): affected all versions; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15563/ (Markdown: https://insights.sbomify.com/CVE-2019-15563/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15563
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15563
- OSV: https://osv.dev/vulnerability/CVE-2019-15563

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15563/
Summaries are generated and may contain mistakes; the official description above is the record.
