CVE-2019-15607 Cross-Site Scripting in node-red

Medium 5.4 Published Updated

Attackers can inject malicious scripts into Node-RED to steal session cookies and deface the application, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-15607?

CVE-2019-15607 is a medium-severity cross-site scripting vulnerability in node-red, published on 28 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A stored XSS vulnerability is present within node-red (version: <= 0.20.7) npm package, which is a visual tool for wiring the Internet of Things. This issue will allow the attacker to steal session cookies, deface web applications, etc.

Weakness: CWE-79

Which versions are affected by CVE-2019-15607?

2 open source packages ship an affected version, including node-red. It affects 1 product.

PackageAffectedFixed in
node-red npmAll versions0.20.8
node-red npmAll versions0.20.8

Products include Nodered Node-Red.

How do I fix CVE-2019-15607?

Upgrade node-red to 0.20.8 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-15607 being exploited?

There is no known exploitation of CVE-2019-15607 in the wild and no public exploit code.

Sources

Also known as GHSA-8w65-xjc5-9w79.

Is CVE-2019-15607 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free