{"answers":{"affected":"2 open source packages ship an affected version, including node-red. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-15607 in the wild and no public exploit code.","fix":"Upgrade node-red to 0.20.8 or later.","what":"CVE-2019-15607 is a medium-severity cross-site scripting vulnerability in node-red, published on 28 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-15607 and fix it if it is affected.\n\nWhat it is: CVE-2019-15607 is a medium-severity cross-site scripting vulnerability in node-red, published on 28 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-15607 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-red (npm): affected all versions; fixed in 0.20.8\n- node-red (npm): affected all versions; fixed in 0.20.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-15607/ (Markdown: https://insights.sbomify.com/CVE-2019-15607/index.md)","id":"CVE-2019-15607","markdown":"https://insights.sbomify.com/CVE-2019-15607/index.md","name":"CVE-2019-15607","record":{"aliases":["GHSA-8w65-xjc5-9w79"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node-RED IoT tool","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into Node-RED to steal session cookies and deface the application, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"node-red","vendor":"nodered"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A stored XSS vulnerability is present within node-red (version: \u003c= 0.20.7) npm package, which is a visual tool for wiring the Internet of Things. This issue will allow the attacker to steal session cookies, deface web applications, etc.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in node-red","id":"CVE-2019-15607","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"TOCTOU Race Condition in Yarn","id":"CVE-2019-15608"},"packages":[{"ecosystem":"npm","fixed":["0.20.8"],"introduced":["0"],"last_affected":[],"package":"node-red","purl":null,"source":"GHSA-8w65-xjc5-9w79"},{"ecosystem":"npm","fixed":["0.20.8"],"introduced":["0"],"last_affected":[],"package":"node-red","purl":"pkg:npm/node-red","source":"GHSA-8w65-xjc5-9w79"}],"prev":{"headline":"Auth bypass in Node","id":"CVE-2019-15606"},"products":["node-red"],"published":"2020-01-28","related":[{"cvss_score":7.7,"headline":"Prototype Pollution in Node-Red","id":"CVE-2021-21297","kev_date_added":null,"published":"2021-02-26"},{"cvss_score":3.5,"headline":"Path traversal in Node-Red","id":"CVE-2021-21298","kev_date_added":null,"published":"2021-02-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts into Node-RED to steal session cookies and deface the application, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2019-15607/"}