# CVE-2019-15608: TOCTOU Race Condition in Yarn

> Attackers can exploit a time-of-check time-of-use flaw in Yarn's cache validation to inject malicious packages, leading to code execution.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2020
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-15608, GHSA-hjxc-462x-x77j

## What is CVE-2019-15608?

CVE-2019-15608 is a medium-severity vulnerability in yarn, published on 15 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition), CWE-840

## Which versions are affected by CVE-2019-15608?

2 open source packages ship an affected version, including yarn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yarn` | npm | All versions | 1.19.0 |
| `yarn` | npm | All versions | 1.19.0 |

Products: Yarnpkg Yarn.

## How do I fix CVE-2019-15608?

Upgrade yarn to 1.19.0 or later.

## Is CVE-2019-15608 being exploited?

There is no known exploitation of CVE-2019-15608 in the wild and no public exploit code.

## Other vulnerabilities in yarn

- [CVE-2019-5448](https://insights.sbomify.com/CVE-2019-5448/): Missing Encryption of Sensitive Data in yarn (high 8.1)
- [CVE-2019-10773](https://insights.sbomify.com/CVE-2019-10773/): Yarn Improper link resolution before file access (Link Following) (high 7.8)
- [CVE-2021-4435](https://insights.sbomify.com/CVE-2021-4435/): Yarn: untrusted search path (high 7.7)
- [CVE-2020-8131](https://insights.sbomify.com/CVE-2020-8131/): Path Traversal in Yarn (high 7.5)
- [CVE-2025-8262](https://insights.sbomify.com/CVE-2025-8262/): yarnpkg Yarn hosted-git-resolver.js explodeHostedGitFragment redos (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15608 and fix it if it is affected.

What it is: CVE-2019-15608 is a medium-severity vulnerability in yarn, published on 15 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-15608 in the wild and no public exploit code.

Affected packages and fixed versions:
- yarn (npm): affected all versions; fixed in 1.19.0
- yarn (npm): affected all versions; fixed in 1.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15608/ (Markdown: https://insights.sbomify.com/CVE-2019-15608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15608
- OSV: https://osv.dev/vulnerability/CVE-2019-15608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15608/
Summaries are generated and may contain mistakes; the official description above is the record.
