# CVE-2019-15609: OS Command Injection and Command Injection in kill-port-process


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Feb 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xp4x-j9vh-c3wf

## What is CVE-2019-15609?

CVE-2019-15609 is a critical vulnerability in kill-port-process, published on 28 Feb 2020. 

### Official description

The kill-port-process package version < 2.2.0 is vulnerable to a Command Injection vulnerability.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2019-15609?

2 open source packages ship an affected version, including kill-port-process. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kill-port-process` | npm | All versions | 2.2.0 |
| `kill-port-process` | npm | All versions | 2.2.0 |

Products: Kill-Port-Process Project Kill-Port-Process.

## How do I fix CVE-2019-15609?

Upgrade kill-port-process to 2.2.0 or later.

## Is CVE-2019-15609 being exploited?

There is no known exploitation of CVE-2019-15609 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-15609 and fix it if it is affected.

What it is: CVE-2019-15609 is a critical vulnerability in kill-port-process, published on 28 Feb 2020. 
Exploitation: There is no known exploitation of CVE-2019-15609 in the wild and no public exploit code.

Affected packages and fixed versions:
- kill-port-process (npm): affected all versions; fixed in 2.2.0
- kill-port-process (npm): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-15609/ (Markdown: https://insights.sbomify.com/CVE-2019-15609/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-15609
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-15609
- OSV: https://osv.dev/vulnerability/CVE-2019-15609

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-15609/
Summaries are generated and may contain mistakes; the official description above is the record.
