CVE-2019-15698 Information disclosure in n/a

Medium 4.3 Published Updated

Authenticated users with VariableView permissions can view sensitive values in Octopus Deploy, requiring an upgrade to remediate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2019-15698?

CVE-2019-15698 is a medium-severity vulnerability in Octopus Octopus Server, published on 27 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Octopus Deploy 2019.7.3 through 2019.7.9, in certain circumstances, an authenticated user with VariableView permissions could view sensitive values. This is fixed in 2019.7.10.

Which versions are affected by CVE-2019-15698?

It affects 1 product.

Products include Octopus Octopus Server.

How do I fix CVE-2019-15698?

No fix has been published for CVE-2019-15698 yet. Limit exposure of the affected software until one is available.

Is CVE-2019-15698 being exploited?

There is no known exploitation of CVE-2019-15698 in the wild and no public exploit code.

All Octopus Octopus Server vulnerabilities

Sources

Also known as GHSA-8xgg-pj9m-c8xj.

Is CVE-2019-15698 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free